aboutsummaryrefslogtreecommitdiffstats
path: root/testing/h1-cli
diff options
context:
space:
mode:
authorAdam Dobrawy <naczelnik@jawnosc.tk>2019-07-16 01:55:56 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-21 22:03:16 -0300
commit34504f6c756f30712be9c92efee1560de586556a (patch)
treee2ae12900a86e4bf23ee8605545e75ae2c8b8593 /testing/h1-cli
parentbd03354bcdd375eb8cf050be58ab552cc495cdbb (diff)
testing/h1-cli: upgrade to 1.6.1
Diffstat (limited to 'testing/h1-cli')
-rw-r--r--testing/h1-cli/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/testing/h1-cli/APKBUILD b/testing/h1-cli/APKBUILD
index 16b27ece56c..67848a36922 100644
--- a/testing/h1-cli/APKBUILD
+++ b/testing/h1-cli/APKBUILD
@@ -1,8 +1,9 @@
# Contributor: Adam Dobrawy <a.dobrawy@hyperone.com>
# Maintainer: Adam Dobrawy <a.dobrawy@hyperone.com>
+# Maintainer: HyperOne staff <pkg-maintainers@hyperone.com>
pkgname=h1-cli
_pkgname=${pkgname/-cli/}
-pkgver=1.6.0
+pkgver=1.6.1
pkgrel=0
pkgdesc="Command-line interface for HyperOne platform"
url="https://www.hyperone.com/tools/cli/"
@@ -16,12 +17,13 @@ options="!strip !check"
build() {
npm install
- npm run-script build
+ npx pkg -c ./package.json -t "node12-alpine" -o "./dist/h1" "./bin/h1"
+ npx pkg -c ./package.json -t "node12-alpine" -o "./dist/rbx" "./bin/rbx"
}
package() {
mkdir -p "$pkgdir"/usr/bin
- cp "$builddir/dist/$_pkgname-alpine" "$pkgdir"/usr/bin/$_pkgname
+ cp "$builddir/dist/$_pkgname" "$pkgdir"/usr/bin/$_pkgname
}
rbx() {
@@ -29,7 +31,7 @@ rbx() {
url="http://rootbox.com/"
cd "$builddir"
mkdir -p "$subpkgdir"/usr/bin
- cp "$builddir/dist/rbx-alpine" "$subpkgdir"/usr/bin/rbx
+ cp "$builddir/dist/rbx" "$subpkgdir"/usr/bin/rbx
}
-sha512sums="10864d8e4727f064d2316f8b11234996c141165aa1fd4b97211d92189c7887b2456e9e991a0a77b0c14c221186d5cacaadeb8f88d350d90f7282ceafa18c2771 h1-cli-1.6.0.tar.gz"
+sha512sums="9043ea20bdc39a60238d94561c48da95f11fda9d57bdd6e9d4802a244ef4df344e72938bfc4e879437c5739d79c83364f1ef0b92ba1f82855896f836b76e7be3 h1-cli-1.6.1.tar.gz"