aboutsummaryrefslogtreecommitdiffstats
path: root/testing/handbrake/APKBUILD
diff options
context:
space:
mode:
authorNathan Angelacos <nangel@alpinelinux.org>2015-09-03 19:43:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-09-05 14:25:49 +0200
commit3e26cc61426f7175b33aed6e16c246458ba770e3 (patch)
treeca53cb14c57a71d115d670fd2c9908a57beeb66e /testing/handbrake/APKBUILD
parent878417ff25eb6ea18861c2e12a336e2625d4b308 (diff)
testing/handbrake: new aport video transcoding tool
handbrake package contains the cli handbrake-gtk subpackage contains the gui
Diffstat (limited to 'testing/handbrake/APKBUILD')
-rw-r--r--testing/handbrake/APKBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/testing/handbrake/APKBUILD b/testing/handbrake/APKBUILD
new file mode 100644
index 00000000000..e17b6ed6168
--- /dev/null
+++ b/testing/handbrake/APKBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Nathan Angelacos <nangel@alpinelinux.org>
+pkgname=handbrake
+_pkgname=HandBrake
+pkgver=0.10.2
+pkgrel=0
+pkgdesc="Handbrake video transcoder"
+url="https://handbrake.fr"
+#pkgusers="$pkgname"
+#pkggroups="$pkgname"
+arch="all"
+license="GPL2"
+install=""
+depends=""
+makedepends="yasm autoconf libtool zlib-dev libbz2 libogg-dev libtheora-dev \
+ libvorbis-dev libsamplerate-dev fribidi-dev freetype-dev \
+ tinyxml-dev fontconfig-dev libass-dev intltool glib-dev dbus-glib-dev \
+ gtk+3.0-dev webkitgtk-dev eudev-dev libnotify-dev libdvdread-dev\
+ gstreamer0.10-dev x264-dev lame-dev linux-headers cmake"
+subpackages="$pkgname-gtk"
+source="${_pkgname}-${pkgver}.tar.bz2::https://handbrake.fr/rotation.php?file=${_pkgname}-${pkgver}.tar.bz2"
+
+_builddir="$srcdir"/${_pkgname}-${pkgver}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr || return 1
+
+ cd build
+ # This is retarded, but handbrake's "custom.defs" doesn't seem to work
+ make ffmpeg.configure
+ make ffmpeg.build CFLAGS="-D_GNU_SOURCE -I${_builddir}/build/contrib/include -I."
+
+ make build CFLAGS="-I${_builddir}/build/contrib/include -I." || return 1
+
+}
+
+package() {
+ cd "$_builddir"/build
+
+ make -j1 install DESTDIR="$pkgdir"
+}
+
+
+gtk() {
+ pkgdesc="HandBrake Video Transcoder - GUI"
+ install -d "$subpkgdir"/usr/bin
+
+ mv "$pkgdir"/usr/bin/ghb "$subpkgdir"/usr/bin/ghb
+ mv "$pkgdir"/usr/share "$subpkgdir"/usr
+
+
+}
+
+md5sums="db0a71147463664c4230ed3f1caf4fe8 HandBrake-0.10.2.tar.bz2"
+sha256sums="4cc3828393b26a982dbe00febd700c5090d3443c1d45492e0b373e02da73c699 HandBrake-0.10.2.tar.bz2"
+sha512sums="7059a88fac1e4810c54880eb4afe58716af7ac81e5b098e34f3a68c19d7c03e51b57e1a196603e2c8d377e94bb3a910d20f1d9ed62d3eab6422031e62730d4a2 HandBrake-0.10.2.tar.bz2"