aboutsummaryrefslogtreecommitdiffstats
path: root/testing/handlebars
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-07-21 13:31:15 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-21 13:36:28 +0200
commit16d6a558c5676c5def9b035ea9ff5fc6dd2da90f (patch)
tree194efd9ea6b39a674d9b935fe4ab5eb31fc68dda /testing/handlebars
parent298d935e11174120ac73d92a97bee621a7f63489 (diff)
testing/handlebars: improve abuild
Diffstat (limited to 'testing/handlebars')
-rw-r--r--testing/handlebars/APKBUILD40
1 files changed, 21 insertions, 19 deletions
diff --git a/testing/handlebars/APKBUILD b/testing/handlebars/APKBUILD
index 1c1fb0713d7..79c802a0737 100644
--- a/testing/handlebars/APKBUILD
+++ b/testing/handlebars/APKBUILD
@@ -1,40 +1,41 @@
-# vim: smartindent noexpandtab tabstop=4 shiftwidth=4
# Contributor: John Boehr <jbboehr@gmail.com>
# Maintainer: Rafael del Valle <rvalle@privaz.io>
-
pkgname=handlebars
+_pkgname=handlebars.c
pkgver=0.6.3
pkgrel=0
-pkgdesc="C implementation library of handlebars.js"
+_mustachespec_ver="1.1.3"
+_handlebarsspec_ver="4.0.5-p1"
+pkgdesc="C implementation of handlebars.js"
url="https://github.com/jbboehr/handlebars.c"
license="LGPLv2.1+"
arch="all"
-
-_mustachespec_ver="1.1.3"
-_handlebarsspec_ver="4.0.5-p1"
-
-depends=""
-makedepends="automake autoconf libtool talloc-dev json-c-dev bison flex yaml-dev lmdb-dev pcre-dev check-dev"
+makedepends="autoconf automake bison check-dev flex json-c-dev libtool lmdb-dev
+ pcre-dev talloc-dev yaml-dev"
subpackages="$pkgname-dev $pkgname-utils"
-
-source="handlebars.c-$pkgver.tar.gz::https://github.com/jbboehr/handlebars.c/archive/v$pkgver.tar.gz
+source="$_pkgname-$pkgver.tar.gz::https://github.com/jbboehr/$_pkgname/archive/v$pkgver.tar.gz
mustache-spec-$_mustachespec_ver.tar.gz::https://github.com/mustache/spec/archive/v$_mustachespec_ver.tar.gz
handlebars-spec-$_handlebarsspec_ver.tar.gz::https://github.com/jbboehr/handlebars-spec/archive/v$_handlebarsspec_ver.tar.gz"
-
-builddir="$srcdir"/handlebars.c-$pkgver
+builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
- rm -rf "$builddir"/spec
- mkdir "$builddir"/spec
- ln -s "$srcdir"/spec-$_mustachespec_ver "$builddir"/spec/mustache
- ln -s "$srcdir"/handlebars-spec-$_handlebarsspec_ver "$builddir"/spec/handlebars
+ cd "$builddir"
+
+ mkdir -p spec
+ ln -sf "$srcdir"/spec-$_mustachespec_ver spec/mustache
+ ln -sf "$srcdir"/handlebars-spec-$_handlebarsspec_ver spec/handlebars
+
default_prepare
+
+ ./bootstrap
}
build() {
cd "$builddir"
- ./bootstrap
- ./configure --prefix=/usr --disable-refcounting
+
+ ./configure \
+ --prefix=/usr \
+ --disable-refcounting
make
}
@@ -50,6 +51,7 @@ package() {
utils() {
pkgdesc="Handlebars command line utilities"
+
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}