aboutsummaryrefslogtreecommitdiffstats
path: root/testing/haproxy/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-14 10:11:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-14 10:11:42 +0000
commiteec9fb558658ce4d651dcc35dc5e8970df2b58a9 (patch)
tree01d583f744b79438f92cfc43fd0af76d62431ce3 /testing/haproxy/APKBUILD
parent56da828f015e84149a39568705fa09633d30c4c5 (diff)
testing/haproxy: add package() function
Diffstat (limited to 'testing/haproxy/APKBUILD')
-rw-r--r--testing/haproxy/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/haproxy/APKBUILD b/testing/haproxy/APKBUILD
index 193350d3a27..fe257dc447e 100644
--- a/testing/haproxy/APKBUILD
+++ b/testing/haproxy/APKBUILD
@@ -16,12 +16,13 @@ source="http://haproxy.1wt.eu/download/1.3/src/$pkgname-$pkgver.tar.gz
build() {
cd "$srcdir/$pkgname-$pkgver"
-
make TARGET=linux26 || return 1
- make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
md5sums="e37046e0cb2f407d92c41d7731d1dd10 haproxy-1.3.20.tar.gz