aboutsummaryrefslogtreecommitdiffstats
path: root/testing/haxe/APKBUILD
diff options
context:
space:
mode:
authorAndy Li <andy@onthewings.net>2018-02-28 14:41:27 +0800
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-01 09:24:45 +0000
commit20eb87e9ab382286ce3222140f87388563909f5e (patch)
tree9194490de7cba29a9769aaf7a430a95e0a9ea774 /testing/haxe/APKBUILD
parentebf14d37f5083963ebbfe3c9a436d0377d463d36 (diff)
testing/haxe: Remove redundant `|| return 1`.
Diffstat (limited to 'testing/haxe/APKBUILD')
-rw-r--r--testing/haxe/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/testing/haxe/APKBUILD b/testing/haxe/APKBUILD
index ccdabc531b7..1018a7c0fda 100644
--- a/testing/haxe/APKBUILD
+++ b/testing/haxe/APKBUILD
@@ -29,20 +29,20 @@ _builddir="$srcdir/$pkgname-$pkgver$_versuffix"
build() {
cd "$_builddir"
- rmdir libs extra/haxelib_src || return 1
- mv "$srcdir"/haxelib-${_commit_haxelib} extra/haxelib_src || return 1
- mv "$srcdir"/ocamllibs-${_commit_ocamllibs} libs || return 1
+ rmdir libs extra/haxelib_src
+ mv "$srcdir"/haxelib-${_commit_haxelib} extra/haxelib_src
+ mv "$srcdir"/ocamllibs-${_commit_ocamllibs} libs
# Check to see if ocamlopt exists. If not, bytecompile everything.
- command -v ocamlopt && make -j1 || make -j1 BYTECODE=1 || return 1
- make -j1 tools || return 1
+ command -v ocamlopt && make -j1 || make -j1 BYTECODE=1
+ make -j1 tools
}
check() {
cd "$_builddir"
- ./haxe -version || return 1
- ./haxelib version || return 1
+ ./haxe -version
+ ./haxelib version
}
package() {