aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hplip
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2020-12-04 11:56:28 +0200
committerTimo Teräs <timo.teras@iki.fi>2020-12-04 11:58:00 +0200
commitb1b094310c29b8f00187f76d3306b3d848c5fedb (patch)
tree289612ed335e1eaed6744961d33e672a06b2e671 /testing/hplip
parent95c248a39ef85a8301282e7fe8335b78d1fa40fb (diff)
testing/hplip: fix hp backend driver
traps: hp[11433] trap invalid opcode ip:7fa5c58013a5 sp:7ffee538db20 error:0 in libhpmud.so.0.0.6[7fa5c57f9000+b000]
Diffstat (limited to 'testing/hplip')
-rw-r--r--testing/hplip/APKBUILD4
-rw-r--r--testing/hplip/fix-memmove.patch12
2 files changed, 15 insertions, 1 deletions
diff --git a/testing/hplip/APKBUILD b/testing/hplip/APKBUILD
index 93c1b7b2669..a2fca5c1bf5 100644
--- a/testing/hplip/APKBUILD
+++ b/testing/hplip/APKBUILD
@@ -4,7 +4,7 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=hplip
pkgver=3.20.5
-pkgrel=1
+pkgrel=2
pkgdesc="Drivers for HP printers and scanners"
arch="x86 x86_64 aarch64 armv7" # missing sane on several arches
url="http://hplipopensource.com"
@@ -14,6 +14,7 @@ makedepends="libjpeg-turbo-dev net-snmp-dev cups-dev libusb-dev sane-dev gawk py
subpackages="$pkgname-doc $pkgname-libs sane-backend-hpaio:sane"
source="https://downloads.sourceforge.net/hplip/hplip-$pkgver.tar.gz
fix-includes.patch
+ fix-memmove.patch
types-musl.patch
disable_upgrade.patch
0025-Remove-all-ImageProcessor-functionality-which-is-clo.patch
@@ -66,6 +67,7 @@ sane() {
sha512sums="fce3c7b8a2f3b0d2875bafd2ff65a3312fae867b658cd45eea16d9f3663646b6b0b70b58e6c2b46eb24627cdeefb318b6ca9ccf5a0e9790ff19519518992da07 hplip-3.20.5.tar.gz
173f0c2bbf0daefc717282bf125d3fd94b3914da0754078c45b58b09ab841672aae9238ca8fc0448486a871e40fc50f960da17c1e07ad3f04053d217ed634498 fix-includes.patch
+7d247b219595a8be4a9d709f14a9034eee1cef467981ffc29d18ee3c00bee125640b1149d7e57e3332242efd978d7cb3f8f25f21d41fb39e38f9520626cfe1ff fix-memmove.patch
dbce7d859661b1a03847edf91db755c9b3d1ad7c2d3173741ecd89b954d1595d71f1adcbd481e81821ebd58cd9ae23adcef1cc026cfa09928fb0cba599781cd1 types-musl.patch
ac436b54aecc0c2a7fc0eb5ae8e28d483c1efd5bd9385b0a1480fb78b8ccdd28ef85db86a980aec5ca093e9095d5714f93df095bf606e9a9c919f07c64e29697 disable_upgrade.patch
0ededf7b27abab1b2f889f19bb3587816d437ed1b8253a68e9e4af99684456057c1529b353c439e11b2235cb84560e90bb841d348fa53b49e4bbc123a41aba81 0025-Remove-all-ImageProcessor-functionality-which-is-clo.patch
diff --git a/testing/hplip/fix-memmove.patch b/testing/hplip/fix-memmove.patch
new file mode 100644
index 00000000000..a7e791ff9d4
--- /dev/null
+++ b/testing/hplip/fix-memmove.patch
@@ -0,0 +1,12 @@
+diff -ru hplip-3.20.5.orig/io/hpmud/musb.c hplip-3.20.5/io/hpmud/musb.c
+--- hplip-3.20.5.orig/io/hpmud/musb.c 2020-05-11 16:33:56.000000000 +0300
++++ hplip-3.20.5/io/hpmud/musb.c 2020-07-06 17:48:24.364564601 +0300
+@@ -775,7 +775,7 @@
+ len = size-1; /* leave byte for zero termination */
+ if (len > 2)
+ len -= 2;
+- memcpy(buffer, buffer+2, len); /* remove length */
++ memmove(buffer, buffer+2, len); /* remove length */
+ buffer[len]=0;
+ DBG("read actual device_id successfully fd=%d len=%d\n", fd, len);
+