summaryrefslogtreecommitdiffstats
path: root/testing/httpie-ntlm
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-25 08:29:28 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-09-29 14:07:38 +0000
commite0c25273f80bbf0c0f78679b97754c9360c20900 (patch)
tree2832cb294162329c1dc75188c080123867848658 /testing/httpie-ntlm
parent010747b4e3de2c6b1f0ca14ace3468b2a17cb66f (diff)
testing/httpie-ntlm: new aport
NTLM plugin for HTTPie https://github.com/jkbr/httpie-ntlm
Diffstat (limited to 'testing/httpie-ntlm')
-rw-r--r--testing/httpie-ntlm/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/httpie-ntlm/APKBUILD b/testing/httpie-ntlm/APKBUILD
new file mode 100644
index 00000000000..c8813f426b0
--- /dev/null
+++ b/testing/httpie-ntlm/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=httpie-ntlm
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="NTLM plugin for HTTPie"
+url="https://github.com/jkbr/httpie-ntlm"
+arch="noarch"
+license="BSD"
+depends="python httpie"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="870b3411af8f846534518439bcbb3beb httpie-ntlm-1.0.2.tar.gz"
+sha256sums="b1f757180c0bd60741ea16cf91fc53d47df402a5c287c4a61a14b335ea0552b3 httpie-ntlm-1.0.2.tar.gz"
+sha512sums="1ad151b0c270fbbdd89e6b6f8dba678e32d8ef4c828e6b359286e0d7001d74243298ac55cc0c2c9989943eb14d96f841227c2c8d709d98b5109bcd1830d95162 httpie-ntlm-1.0.2.tar.gz"