aboutsummaryrefslogtreecommitdiffstats
path: root/testing/i2pd
diff options
context:
space:
mode:
authorR4SAS <r4sas@users.noreply.github.com>2019-05-10 05:15:43 +0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-10 10:38:49 +0000
commit4bb55736b3c65d9ca9c261f331bc71df3c759aa3 (patch)
treeca72837edce9191fa38f42010a4568e0c985144d /testing/i2pd
parentdefabc9612346b88f5295650d0c367bb923dee43 (diff)
testing/i2pd: upgrade to 2.25.0
Closes GH-7761
Diffstat (limited to 'testing/i2pd')
-rw-r--r--testing/i2pd/APKBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/testing/i2pd/APKBUILD b/testing/i2pd/APKBUILD
index e3eea40bfa3..4e8d85bf7fe 100644
--- a/testing/i2pd/APKBUILD
+++ b/testing/i2pd/APKBUILD
@@ -1,23 +1,22 @@
# Contributor: l-n-s <supervillain@riseup.net>
# Maintainer: l-n-s <supervillain@riseup.net>
pkgname=i2pd
-pkgver=2.24.0
-pkgrel=1
+pkgver=2.25.0
+pkgrel=0
pkgdesc="I2P Router written in C++"
url="https://github.com/PurpleI2P/i2pd"
arch="all"
-license="BSD"
+license="BSD-3-Clause"
pkgusers="i2pd"
depends="musl-utils"
-makedepends="boost-dev openssl-dev openssl zlib-dev"
-options="!check"
+makedepends="boost-dev openssl-dev zlib-dev"
+options="!check" # No test suite
install="$pkgname.pre-install"
source="https://github.com/PurpleI2P/i2pd/archive/$pkgver/$pkgname-$pkgver.tar.gz
i2pd.initd
i2pd.confd
"
subpackages="$pkgname-openrc"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
local _arch_opts=
@@ -26,13 +25,10 @@ build() {
aarch64|arm*) _arch_opts="USE_AESNI=no USE_AVX=no" ;;
esac
- cd "$builddir"
make $_arch_opts
}
package() {
- cd "$builddir"
-
install -D -m 755 i2pd "$pkgdir"/usr/sbin/i2pd
install -dm755 -o $pkgusers \
@@ -52,6 +48,6 @@ package() {
"$pkgdir"/etc/conf.d/$pkgname
}
-sha512sums="89364943ab4d7344c3e7e79759b051710ca7ebb9021220904c112ebd6adac84fac37627c191ed06de5c4aba799a3157f680382b227499d26976ae1a742151514 i2pd-2.24.0.tar.gz
+sha512sums="e45318236b7a4e23c8dc83423f4cbc62e622a6f6346a67d56af09b805a82f1d1bf4174c9785078292ad07fc7e5e75f15d3fcc801e44fddcbd8c30d6c7bd6975e i2pd-2.25.0.tar.gz
5a95beef635fc2f5beecee314964fd41713ed61f92c4e972276208e0a2c86604c2b42a8e922863fc658a7a5789c9f43fddf7f76350fc281a44f2f42258a01201 i2pd.initd
ba94e5505f4eeb9a32159aa0a3b7f68ff077abb9704800f70502ac75fd5bcfcb20450ebd983d0523beca2d13e718d7bf888f53ec455d1f41701c16d09c3b2d28 i2pd.confd"