aboutsummaryrefslogtreecommitdiffstats
path: root/testing/icewm/APKBUILD
diff options
context:
space:
mode:
authorIsaac Dunham <ibid.ag@gmail.com>2014-07-04 18:10:21 -0700
committerNatanael Copa <ncopa@alpinelinux.org>2014-07-08 07:40:34 +0000
commit8b7245596cb245a424f00548646c9162b5ff42ce (patch)
tree430011fd6791f8a66ed7bd7513b095146491df26 /testing/icewm/APKBUILD
parentb6ecb2636c7f0613773f922c290dc02c890c4d8f (diff)
testing/icewm: make menu useable by default
* Add the more typical terminal emulators to the default menu * use Firefox/Midori instead of Mozilla This way, users are able to at least get a command line, and standard browsers show up. Icewm will search $PATH for the command at startup, and only shows it if the command is present.
Diffstat (limited to 'testing/icewm/APKBUILD')
-rw-r--r--testing/icewm/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/testing/icewm/APKBUILD b/testing/icewm/APKBUILD
index 7a4d36eaffa..9fcd7f882db 100644
--- a/testing/icewm/APKBUILD
+++ b/testing/icewm/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
pkgname=icewm
pkgver=1.3.8
-pkgrel=2
+pkgrel=3
pkgdesc="A lightweight Win95/Motif-style window manager in C++"
url="http://www.icewm.org"
arch="all"
@@ -47,6 +47,12 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm -f "$pkgdir"/usr/lib/*.la
+ sed -e 's/rxvt/urxvt/g' \
+ -e 's/\(prog xterm.*\)/\1\nprog Terminal xterm xfce4-terminal/' \
+ -e 's/\(prog xterm.*\)/\1\nprog st xterm st/' \
+ -e 's/\(prog xterm.*\)/\1\nprog mrxvt xterm mrxvt/' \
+ -e 's/prog Mozil.*/\nprog Firefox mozilla firefox\nprog Midori midori midori/' \
+ -i "$pkgdir"/usr/share/icewm/menu
}
doc() {
cd "$_builddir"