aboutsummaryrefslogtreecommitdiffstats
path: root/testing/imgbrd-grabber/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-12-19 13:45:36 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-01-04 20:03:01 +0100
commitd33b26afd532c021810d466a6c1a229d6e187ca3 (patch)
tree37f7eaaf815ae3bc4c570855a30a684481f52d3d /testing/imgbrd-grabber/APKBUILD
parentca1961dea4e1ac1ed068861608889799117ff5ef (diff)
community/qt5-qtdeclarative: disable on armhf
It is broken currently (and probably forever), upstream bug report https://bugreports.qt.io/browse/QTBUG-65246 Disable armhf for all packages that depend on qt5-qtdeclarative in one way or another
Diffstat (limited to 'testing/imgbrd-grabber/APKBUILD')
-rw-r--r--testing/imgbrd-grabber/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/testing/imgbrd-grabber/APKBUILD b/testing/imgbrd-grabber/APKBUILD
index d84a0e6b744..dd7da31e89f 100644
--- a/testing/imgbrd-grabber/APKBUILD
+++ b/testing/imgbrd-grabber/APKBUILD
@@ -6,12 +6,12 @@ pkgrel=0
pkgdesc="Powerful imageboard/booru downloader"
options="!check" # Tests requires graphics
url="https://bionus.github.io/imgbrd-grabber"
-arch="all !mips64 !mips64el" # nodejs restrictions
+arch="all !mips64 !mips64el !armhf" # mps64 and mips64el blocked by nodejs restrictions, armhf blocked by qt5-qtdeclarative
license="Apache-2.0"
makedepends="cmake nodejs qt5-qtdeclarative-dev qt5-qtmultimedia-dev
qt5-qtbase-mysql qt5-qtbase-odbc qt5-qtbase-sqlite qt5-qtbase-tds
qt5-qtscript-dev qt5-qtbase-dev qt5-qttools-dev npm"
-source="$pkgname-$pkgver.tar.gz::https://github.com/Bionus/imgbrd-grabber/archive/v${pkgver}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Bionus/imgbrd-grabber/archive/v$pkgver.tar.gz"
build() {
sed -i 's|USE_QSCINTILLA 1|USE_QSCINTILLA 0|' gui/CMakeLists.txt
@@ -27,7 +27,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ $CMAKE_CROSSOPTS
make
}