aboutsummaryrefslogtreecommitdiffstats
path: root/testing/irclog2html/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-06-16 11:38:25 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-06-18 16:26:28 +0000
commit55927855199e270041f89c5df4eed0a1b584095c (patch)
treea2a7e4d7b612a9153b1a47d2ec7e6ebaa790c9a6 /testing/irclog2html/APKBUILD
parent8fd41816f4868e659e747f100828ada1264dbe0f (diff)
testing/irclog2html: new aport
irclog2html is a nice IRC log parser and colorizer that will do the most common things necessary to make an IRC log readable in a web browser. It can export to many different HTML formats, and can export MediaWiki pipe-table syntax. http://mg.pov.lt/irclog2html/
Diffstat (limited to 'testing/irclog2html/APKBUILD')
-rw-r--r--testing/irclog2html/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/irclog2html/APKBUILD b/testing/irclog2html/APKBUILD
new file mode 100644
index 00000000000..37474590b1a
--- /dev/null
+++ b/testing/irclog2html/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=irclog2html
+pkgver=2.10.0
+pkgrel=0
+pkgdesc="Script to convert IRC logs to HTML and other formats"
+url="http://mg.pov.lt/irclog2html/"
+arch="noarch"
+license="GPL2+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/i/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ install -Dpm 0644 src/$pkgname/irclog.css \
+ "$pkgdir"/usr/share/$pkgname/irclog.css || return 1
+}
+
+md5sums="22146b05fde89e27b8f98e95ab219113 irclog2html-2.10.0.tar.gz"