aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ispc/APKBUILD
diff options
context:
space:
mode:
authorLeon Marz <main@lmarz.org>2021-07-01 16:29:01 +0200
committerLeo <thinkabit.ukim@gmail.com>2021-07-01 21:36:35 +0000
commitab9edeb1399c3be9ded1f4b66da1c4137a731696 (patch)
treeb82e724bcc75a55937c0e91ca8f41b18b14099c4 /testing/ispc/APKBUILD
parent962b5002be208d2f6bc4d37cc09bad33013f06d6 (diff)
testing/ispc: new aport
https://ispc.github.io Intel SPMD Program Compiler
Diffstat (limited to 'testing/ispc/APKBUILD')
-rw-r--r--testing/ispc/APKBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/testing/ispc/APKBUILD b/testing/ispc/APKBUILD
new file mode 100644
index 00000000000..1e109a909c3
--- /dev/null
+++ b/testing/ispc/APKBUILD
@@ -0,0 +1,56 @@
+# Contributor: Leon Marz <main@lmarz.org>
+# Maintainer: Leon Marz <main@lmarz.org>
+pkgname=ispc
+pkgver=1.16.0
+pkgrel=0
+pkgdesc="Intel SPMD Program Compiler"
+url="https://ispc.github.io"
+arch="x86_64 armv7 aarch64" # ispc only supports these arches
+license="BSD-3-Clause"
+_llvmver=llvm11
+makedepends="cmake
+ bison
+ clang-dev
+ clang-static
+ flex
+ $_llvmver-dev
+ $_llvmver-static
+ $_llvmver-test-utils
+ m4
+ ncurses-dev
+ zlib-dev"
+# subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ispc/ispc/archive/v$pkgver.tar.gz
+ 0001-tinfo.patch
+ "
+options="!check" # ctest does not find a testsuite
+
+build() {
+ _x86_enabled=OFF
+ _arm_enabled=OFF
+ case "$CARCH" in
+ x86_64) _x86_enabled=ON ;;
+ armv7|aarch64) _arm_enabled=ON ;;
+ esac
+
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=True \
+ -DCLANG_EXECUTABLE="$(command -v clang)" \
+ -DCLANGPP_EXECUTABLE="$(command -v clang++)" \
+ -DX86_ENABLED=$_x86_enabled \
+ -DARM_ENABLED=$_arm_enabled \
+ -DISPC_INCLUDE_EXAMPLES=OFF \
+ -DISPC_NO_DUMPS=ON
+
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+8469db4e3e9834477345b431162543f1c8e680aa9834c9a50239781dc7febfdde0561c2f13d1387e37f95a18c4376a85cb9cbae33cb614dc8977dfc9f47da215 ispc-1.16.0.tar.gz
+f22261c96b778228ff63db4273ec25e2081f870a01a56765ec64ebc5b72909c5be527bb065503afbdd24821df8776bcf9a9147f6d1bdaec3776339685097614d 0001-tinfo.patch
+"