aboutsummaryrefslogtreecommitdiffstats
path: root/testing/j4-dmenu-desktop
diff options
context:
space:
mode:
authorBradley Saulteaux <bradsoto@gmail.com>2019-02-05 08:41:51 -0700
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-06 07:12:29 +0000
commitafb8ebf60fe72c29776c128964ccf31a3ea75c95 (patch)
treee0b20f86a924790737e4cfc6926bf4557616c42f /testing/j4-dmenu-desktop
parentde39882631154f13d245e622d5b8d115d7c9b087 (diff)
testing/j4-dmenu-desktop: new aport
https://github.com/enkore/j4-dmenu-desktop A fast desktop menu
Diffstat (limited to 'testing/j4-dmenu-desktop')
-rw-r--r--testing/j4-dmenu-desktop/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/j4-dmenu-desktop/APKBUILD b/testing/j4-dmenu-desktop/APKBUILD
new file mode 100644
index 00000000000..d30e13c8ae2
--- /dev/null
+++ b/testing/j4-dmenu-desktop/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Bradley Saulteaux <bradsoto@gmail.com>
+pkgname=j4-dmenu-desktop
+pkgver=2.16
+pkgrel=0
+pkgdesc="A fast desktop menu"
+url="https://github.com/enkore/${pkgname}"
+arch="all"
+license="GPL-3.0-only"
+depends="dmenu"
+makedepends="cmake git"
+install=""
+subpackages=""
+source="${pkgname}-${pkgver}.tar.gz::${url}/archive/r${pkgver}.tar.gz"
+builddir="$srcdir"/$pkgname-r$pkgver
+
+build() {
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="d5bb0902d4bdc474fa20bc9d8f79de90a92bb4941f0d325dfcfaa1347ea3ad355b87da8194bc3f654970e9ab8848e6ecb5093f3c75fbaa8dbc40199fe6ea2837 j4-dmenu-desktop-2.16.tar.gz"