aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kannel
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 00:55:45 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-27 00:55:45 -0300
commit7bf71634a94eb8dbd151d20923cad842bfc806e8 (patch)
tree3be5cbc5396915572e0954d6d57b671a55e369a5 /testing/kannel
parentdfac60e989ded06af01a4eaaa8b4e6a6b449662d (diff)
testing/kannel: fix url
Diffstat (limited to 'testing/kannel')
-rw-r--r--testing/kannel/APKBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/testing/kannel/APKBUILD b/testing/kannel/APKBUILD
index 1e64d7ad580..ff427f5fb2a 100644
--- a/testing/kannel/APKBUILD
+++ b/testing/kannel/APKBUILD
@@ -2,15 +2,13 @@
# Maintainer:
pkgname=kannel
pkgver=1.5.0
-pkgrel=7
+pkgrel=8
pkgdesc="Opensource WAP/SMS Gateway"
-url="http://www.kannel.org"
+url="https://www.kannel.org/"
arch="all"
license="custom"
-depends=""
depends_dev="libxml2-dev mariadb-connector-c-dev postgresql-dev pcre-dev sqlite-dev"
makedepends="$depends_dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://www.kannel.org/download/$pkgver/gateway-$pkgver.tar.bz2
$pkgname-bearerbox.initd
@@ -26,12 +24,11 @@ source="http://www.kannel.org/download/$pkgver/gateway-$pkgver.tar.bz2
builddir="$srcdir"/gateway-$pkgver
prepare() {
- default_prepare || return 1
- update_config_guess || return 1
+ default_prepare
+ update_config_guess
}
build() {
- cd "$builddir"
./configure \
--prefix=/usr \
--sbindir=/usr/bin \
@@ -41,11 +38,10 @@ build() {
--with-mysql
touch .depend
make depend
- make || return 1
+ make
}
package() {
- cd "$builddir"
make DESTDIR=$pkgdir install
make DESTDIR=$pkgdir install-test
mkdir -p $pkgdir/var/log/kannel/