aboutsummaryrefslogtreecommitdiffstats
path: root/testing/karchive
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-22 00:38:15 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-28 17:14:47 +0000
commit2b8e259413d7b28af319dddcc11b37c45f2e201c (patch)
treea5d3964f237a9b2540f2345b080400cf7dbed14b /testing/karchive
parentd153c3f4952d45419cf00f9f7d3742b34d5a8da4 (diff)
testing/karchive: new aport
Closes GH-7992
Diffstat (limited to 'testing/karchive')
-rw-r--r--testing/karchive/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/karchive/APKBUILD b/testing/karchive/APKBUILD
new file mode 100644
index 00000000000..1bfe7aafd44
--- /dev/null
+++ b/testing/karchive/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=karchive
+pkgver=5.58.0
+pkgrel=0
+pkgdesc="Qt 5 addon providing access to numerous types of archives"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.0-only AND LGPL-2.1-or-later"
+makedepends="extra-cmake-modules doxygen qt5-qttools-dev"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="fd3e4f013a18a2e2876a010ba673c207a8cc05f3e41723daf46181f915259a06ba63e02d0d47cbf9da0445da94ce02cc62cee4fb90d0da2323c3e51a4d3e4d35 karchive-5.58.0.tar.xz"