aboutsummaryrefslogtreecommitdiffstats
path: root/testing/keepalived/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-15 15:20:06 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-15 18:12:34 +0200
commitd3b04f36b465b1cb02976185aa63ed2fefc94405 (patch)
tree1927b7ff899f85ae80510ea87989869aa9bf55d8 /testing/keepalived/APKBUILD
parent9670a553745cb02dbf5c53921ae9d9c418c3f9da (diff)
testing/keepalived: improve abuild
Diffstat (limited to 'testing/keepalived/APKBUILD')
-rw-r--r--testing/keepalived/APKBUILD32
1 files changed, 10 insertions, 22 deletions
diff --git a/testing/keepalived/APKBUILD b/testing/keepalived/APKBUILD
index 86876e6f132..e30b8e8d66a 100644
--- a/testing/keepalived/APKBUILD
+++ b/testing/keepalived/APKBUILD
@@ -7,32 +7,18 @@ pkgdesc="Health Checking for Linux Virtual Server & High-Availability"
url="http://www.keepalived.org/"
arch="all"
license="GPL"
-depends=
+depends=""
makedepends="openssl-dev popt-dev linux-headers net-snmp-dev libnl-dev"
-install=""
subpackages="$pkgname-doc $pkgname-sample-config:samples"
source="http://www.keepalived.org/software/$pkgname-$pkgver.tar.gz
$pkgname.initd
$pkgname.confd
"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
- # apply patches here
- for i in $source; do
- case $i in
- *.patch)
- msg "Applying $i"
- patch -p1 -i "$srcdir"/$i || return 1
- ;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
+
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -48,13 +34,13 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
+
make DESTDIR="$pkgdir" install || return 1
- mkdir -p "$pkgdir"/usr/share/doc/$pkgname/genhash
- for f in AUTHOR CONTRIBUTORS ChangeLog README INSTALL TODO \
+ local f; for f in AUTHOR CONTRIBUTORS ChangeLog README INSTALL TODO \
genhash/README genhash/AUTHOR genhash/ChangeLog; do
- install -m644 $f "$pkgdir"/usr/share/doc/$pkgname/$f || return 1
+ install -m644 -D $f "$pkgdir"/usr/share/doc/$pkgname/$f || return 1
done
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
@@ -66,6 +52,8 @@ package() {
samples() {
pkgdesc="Sample configuration for keepalived"
+ arch="noarch"
+
mkdir -p "$subpkgdir"/etc/keepalived/
mv "$pkgdir"/etc/keepalived/samples "$subpkgdir"/etc/keepalived/
}