aboutsummaryrefslogtreecommitdiffstats
path: root/testing/keynav/APKBUILD
diff options
context:
space:
mode:
authorMiles Alan <m@userbound.com>2020-05-31 08:41:06 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-05-31 08:41:06 +0000
commite7cb1bae99fd7d06aa39bd8d0619a40e729b9f8c (patch)
treeefc7a3aaecc486222e4ec862ccdf9dcff328c6ed /testing/keynav/APKBUILD
parentde95dd7af7104f2e457eed2ad2d30aecdf32fb5d (diff)
testing/keynav: new aport
https://www.semicomplete.com/projects/keynav/ Quick way to use cursor via the keyboard
Diffstat (limited to 'testing/keynav/APKBUILD')
-rw-r--r--testing/keynav/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/keynav/APKBUILD b/testing/keynav/APKBUILD
new file mode 100644
index 00000000000..ab6b605bffc
--- /dev/null
+++ b/testing/keynav/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Miles Alan <m@milesalan.com>
+pkgname=keynav
+pkgver=0_git20180820
+_gitrev="78f9e076a5618aba43b030fbb9344c415c30c1e5"
+pkgrel=0
+pkgdesc="Quick way to use cursor via the keyboard"
+url="https://www.semicomplete.com/projects/keynav/"
+arch="all"
+license="BSD-3-Clause"
+depends="xorg-server"
+makedepends="cairo-dev libxinerama-dev xdotool-dev glib-dev libxrandr-dev perl"
+checkdepends="xvfb"
+subpackages="$pkgname-doc"
+source="https://github.com/jordansissel/keynav/archive/$_gitrev/keynav-$_gitrev.tar.gz"
+builddir="$srcdir/keynav-$_gitrev"
+
+build() {
+ make
+}
+
+check() {
+ ./test.sh
+}
+
+package() {
+ install -Dm0755 keynav $pkgdir/usr/bin/keynav
+ make keynav.1
+ install -Dm644 ./*.1 -t $pkgdir/usr/share/man/man1/
+}
+sha512sums="5e0e3c4cf3b89a2ffecfc662d379864f18cfa0f9117564cc1f551757dc46e5a4684c3fea0891ae39da872ece9ef44b8b81fa51f0843457d4895db8517d7bd094 keynav-78f9e076a5618aba43b030fbb9344c415c30c1e5.tar.gz"