aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kglobalaccel
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 07:47:15 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 12:05:35 +0000
commit0ceaac40de25a770fc1d1bad35f38c71c526dfe0 (patch)
tree4367b8881df64f1d24bfdd79306227dd9bf1c15b /testing/kglobalaccel
parent6f252a7ffdd0ab3bba44673017123f0120047f3d (diff)
testing/kglobalaccel: use xvfb-run to run testsuite
Closes GH-8390
Diffstat (limited to 'testing/kglobalaccel')
-rw-r--r--testing/kglobalaccel/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/testing/kglobalaccel/APKBUILD b/testing/kglobalaccel/APKBUILD
index 86e730ea8b4..d2a204c120e 100644
--- a/testing/kglobalaccel/APKBUILD
+++ b/testing/kglobalaccel/APKBUILD
@@ -9,9 +9,9 @@ url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="qt5-qtx11extras-dev kconfig-dev kcoreaddons-dev kcrash-dev kdbusaddons-dev kwindowsystem-dev"
makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev xcb-util-keysyms-dev"
+checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-options="!check" # Fails due to requiring running X11
build() {
cmake \
@@ -23,7 +23,7 @@ build() {
}
check() {
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {