aboutsummaryrefslogtreecommitdiffstats
path: root/testing/khotkeys/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-07 14:20:12 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 10:22:49 -0300
commitdfed8da74c3d2df7f478b8daead28a57846ad723 (patch)
tree922654b409c15ff4a8691b2be5ee28e3a4cb0e28 /testing/khotkeys/APKBUILD
parent7856f4225c2237d427428c1c772edb7ec80909f9 (diff)
testing/khotkeys: new aport
Diffstat (limited to 'testing/khotkeys/APKBUILD')
-rw-r--r--testing/khotkeys/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/khotkeys/APKBUILD b/testing/khotkeys/APKBUILD
new file mode 100644
index 00000000000..bb5f17c98d6
--- /dev/null
+++ b/testing/khotkeys/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=khotkeys
+pkgver=5.16.5
+pkgrel=0
+arch="all"
+url="https://www.kde.org/workspaces/plasmadesktop/"
+pkgdesc="Key Accelerator Application"
+license="GPL-2.0-only AND LGPL-2.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtx11extras-dev kglobalaccel-dev ki18n-dev kio-dev kxmlgui-dev kdelibs4support-dev kdbusaddons-dev kcmutils-dev plasma-framework-dev plasma-workspace-dev kdoctools-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/khotkeys-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang $pkgname-dev"
+options="!check" # No tests
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="f389396c058dc261a16f6a73f88babc24dc1d7226e35d798c77629bd3e15f1dc9bc2923f2eedb601df6517b168c251c8c6341f364ee14facf4d267e9e5358f34 khotkeys-5.16.5.tar.xz"