aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ktexteditor/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 19:07:07 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-03 04:39:38 +0000
commit088c623566f251a9f480b1b1d6507924704525cf (patch)
tree328067d3883b2d570851e17d9939f346cc24cbea /testing/ktexteditor/APKBUILD
parent770e593b2c774596ff1e689569a0779832157e87 (diff)
testing/ktexteditor: use xvfb-run to run testsuite
Closes GH-8419
Diffstat (limited to 'testing/ktexteditor/APKBUILD')
-rw-r--r--testing/ktexteditor/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/ktexteditor/APKBUILD b/testing/ktexteditor/APKBUILD
index bd63bb29e5e..b628fad1fde 100644
--- a/testing/ktexteditor/APKBUILD
+++ b/testing/ktexteditor/APKBUILD
@@ -6,12 +6,13 @@ pkgrel=0
pkgdesc="Advanced embeddable text editor"
arch="all"
url="https://community.kde.org/Frameworks"
-license="LGPL-2.1-only AND LGPL-2.1+ AND (LGPL-2.1-only OR LGPL-3.0-only)"
+license="LGPL-2.1-only AND LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends_dev="karchive-dev kconfig-dev kguiaddons-dev ki18n-dev kio-dev kparts-dev sonnet-dev kiconthemes-dev syntax-highlighting-dev kauth-dev"
makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
+checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-options="!check" # Fails due to requiring running X11
+# options="!check" # Fails due to requiring running X11
build() {
cmake \
@@ -23,7 +24,7 @@ build() {
}
check() {
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {