aboutsummaryrefslogtreecommitdiffstats
path: root/testing/laz-perf
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-22 20:04:29 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-07 01:54:56 -0300
commit2b51c97f9bd1d987750eb645137c98e6674b93de (patch)
tree14896ad0c6bed73cfab4551afe1e317e755c18da /testing/laz-perf
parent3893978ce77000fc6cf5b8ab30c13becded03606 (diff)
testing/laz-perf: modernize
Diffstat (limited to 'testing/laz-perf')
-rw-r--r--testing/laz-perf/APKBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/testing/laz-perf/APKBUILD b/testing/laz-perf/APKBUILD
index ac8b56d3994..e94f946bbaf 100644
--- a/testing/laz-perf/APKBUILD
+++ b/testing/laz-perf/APKBUILD
@@ -8,30 +8,26 @@ url="https://github.com/hobu/laz-perf"
arch="all !armhf !armv7 !s390x" # armhf: io_test segfaults
license="LGPL-2.0-or-later"
makedepends="cmake"
-install=""
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/hobu/$pkgname/archive/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
-
- mkdir build && cd build
- cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DWITH_TESTS=ON
- make
+ mkdir build && cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DWITH_TESTS=ON
+ make
}
check() {
- cd "$builddir"/build
- make test
+ cd "$builddir"/build
+ make test
}
package() {
- cd "$builddir"/build
- make DESTDIR="$pkgdir" install
+ cd "$builddir"/build
+ make DESTDIR="$pkgdir" install
}
sha512sums="f6e52e48848d4c409c7620b111b74160369f0cd5fd48c1a711139cc0337aea8dd9401fb0e098593f24edb2d71d910ca05931d3a411639d8aaf5183b7288ba8d0 laz-perf-1.2.0.tar.gz"