aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libaccounts-glib/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-21 17:57:08 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-22 16:08:11 -0300
commit50cc96b75c69ffb5801d150a1b6ed0fe8a2156f1 (patch)
tree97a9f18470eb9dd12a55a6182d061a09b00ff7de /testing/libaccounts-glib/APKBUILD
parentf836cebd11291aa48d44be1b5aa0f025173b4f24 (diff)
testing/libaccounts-glib: new aport
Diffstat (limited to 'testing/libaccounts-glib/APKBUILD')
-rw-r--r--testing/libaccounts-glib/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/libaccounts-glib/APKBUILD b/testing/libaccounts-glib/APKBUILD
new file mode 100644
index 00000000000..323a52bca18
--- /dev/null
+++ b/testing/libaccounts-glib/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libaccounts-glib
+pkgver=1.24
+pkgrel=0
+arch="all"
+url="https://gitlab.com/accounts-sso/libaccounts-glib"
+pkgdesc="GLib-based client library for the accounts database"
+license="LGPL-2.1-or-later"
+depends_dev="libxml2-dev sqlite-dev check-dev py3-gobject3 gobject-introspection-dev"
+makedepends="$depends_dev meson ninja vala python3 gtk-doc glib-dev"
+source="https://gitlab.com/accounts-sso/$pkgname/-/archive/VERSION_$pkgver/$pkgname-VERSION_$pkgver.tar.gz"
+subpackages="$pkgname-dev $pkgname-doc"
+options="!check" # Requires a systemd feature
+builddir="$srcdir/$pkgname-VERSION_$pkgver"
+
+build() {
+ meson build --prefix=/usr
+ ninja -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+sha512sums="d4e6906f642c7a196cb42172f31345f58037d528950bee3af2b8cb388aea386056cbaa22f0e7c604a4e00038b231e9ee455f6a1d48f82344cfc0037ad7251b7c libaccounts-glib-VERSION_1.24.tar.gz"