aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libbaseencode/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-01 12:43:19 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-02 04:38:01 +0000
commitd38b2a2c033ad638e9ac83e694e49a3bb4f7d786 (patch)
tree17dd5d547f7d19cef5d4fceb762267bfadb03ddd /testing/libbaseencode/APKBUILD
parent7b83b04248140477097afbd487ae970583df3f00 (diff)
testing/libbaseencode: new aport
Simple C99 Base16, Base32 and Base64 encode and decode library https://github.com/tspspi/libbaseencode
Diffstat (limited to 'testing/libbaseencode/APKBUILD')
-rw-r--r--testing/libbaseencode/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/libbaseencode/APKBUILD b/testing/libbaseencode/APKBUILD
new file mode 100644
index 00000000000..5a75b52d77e
--- /dev/null
+++ b/testing/libbaseencode/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=libbaseencode
+pkgver=1.0.9
+pkgrel=0
+pkgdesc="Library for encoding decoding data use base32 or base64"
+options="!check" # No woerking testsuite
+url="https://github.com/paolostivanin/libbaseencode"
+arch="all"
+license="Apache-2.0"
+makedepends="cmake"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/paolostivanin/libbaseencode/archive/v${pkgver}.tar.gz"
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=Release
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="26f3c8db6d72aad77fab9d6cdfe94e39891d7afff44d30af79926af72f1af97b8108a8226f376bd0bd3c8c02167a512604c7a52d16a8bce4167a7bdd4a2e603f libbaseencode-1.0.9.tar.gz"