aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libbytesize/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-25 08:37:52 +0000
committerAndy Postnikov <apostnikov@gmail.com>2018-04-26 05:11:34 +0300
commit543d9257212290eb0cb27f9e86b7fdc81662b4fe (patch)
tree63056bbc7d93a1df5a24d5395eb3ba0c7df20701 /testing/libbytesize/APKBUILD
parentbaee05d0e3079214df35e0819f4d657b9604734d (diff)
testing/libbytesize: clarify license, improve abuild
Diffstat (limited to 'testing/libbytesize/APKBUILD')
-rw-r--r--testing/libbytesize/APKBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/testing/libbytesize/APKBUILD b/testing/libbytesize/APKBUILD
index c5f1c53c1cd..52fa5c9d3a7 100644
--- a/testing/libbytesize/APKBUILD
+++ b/testing/libbytesize/APKBUILD
@@ -3,14 +3,13 @@
pkgname=libbytesize
pkgver=1.3
pkgrel=0
-pkgdesc="A tiny library providing a C 'class' for working with arbitrary big sizes in bytes"
+pkgdesc="Library for working with arbitrary big sizes in bytes"
url="https://github.com/rhinstaller/libbytesize"
arch="all"
-license="LGPL"
-makedepends="pcre-dev mpfr-dev gmp-dev gettext-dev python3"
+license="LGPL-2.1-or-later"
+makedepends="gettext-dev gmp-dev mpfr-dev pcre-dev python3"
subpackages="$pkgname-dev $pkgname-lang py-$pkgname:py"
-source="https://github.com/storaged-project/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/"$pkgname-$pkgver
+source="https://github.com/storaged-project/libbytesize/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
build() {
cd "$builddir"
@@ -25,7 +24,7 @@ package() {
py() {
pkgdesc="Python bindings for $pkgname"
-
+
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}