summaryrefslogtreecommitdiffstats
path: root/testing/libecap
diff options
context:
space:
mode:
authorRoger Newman <roger.newman@riseup.net>2017-03-04 17:21:27 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-03-09 07:59:33 +0000
commit001f6137c85e064c00d46915b5464f28c7319d14 (patch)
treef566ccd4e6eea79e53cba73b47e5d87384360000 /testing/libecap
parente1d2b1f16e15a2176042b266c15d6e176c4492e8 (diff)
testing/libecap: new aport
http://www.e-cap.org/ API for implementing ICAP content analysis and adaptation
Diffstat (limited to 'testing/libecap')
-rw-r--r--testing/libecap/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/libecap/APKBUILD b/testing/libecap/APKBUILD
new file mode 100644
index 00000000000..dd9ec71816b
--- /dev/null
+++ b/testing/libecap/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Roger Newman <roger.newman@riseup.net>
+# Maintainer: Roger Newman <roger.newman@riseup.net>
+pkgname=libecap
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="API for implementing ICAP content analysis and adaptation"
+url="http://www.e-cap.org/"
+arch="all"
+license="BSD"
+depends=""
+subpackages="$pkgname-dev"
+source="http://www.measurement-factory.com/tmp/ecap/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ default_prepare || return 1
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --libdir=/lib \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install-strip \
+ libdir=/usr/lib \
+ pkgconfigdir="/usr/lib/pkgconfig" \
+ DESTDIR="$pkgdir" || return 1
+}
+
+sha512sums="7d34b5a9b6843d6b09efc4fa390c7a2d3dda7a2ae5e82d5021295e436ca9afb7c1f70bc6f25a68e4c430fb6e33ee9f602655c9c830fccd46a8f554774813b452 libecap-1.0.0.tar.gz"