aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libieee1284
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-07-25 19:23:40 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-25 19:23:40 +0200
commit69933189a47471b11eed6edc77c593182e89b5e3 (patch)
tree84406a96a01962dd7cafe0f5825a3e67d0b5ec75 /testing/libieee1284
parent04a497c2453960d0add42b95639554542708790f (diff)
testing/libieee1284: improve abuild
Diffstat (limited to 'testing/libieee1284')
-rw-r--r--testing/libieee1284/APKBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/testing/libieee1284/APKBUILD b/testing/libieee1284/APKBUILD
index 1728ae1d786..f68e88554ef 100644
--- a/testing/libieee1284/APKBUILD
+++ b/testing/libieee1284/APKBUILD
@@ -3,36 +3,34 @@
pkgname=libieee1284
pkgver=0.2.11
pkgrel=0
-pkgdesc="libieee1284 is a cross-platform library for parallel port access"
+pkgdesc="A cross-platform library for parallel port access"
url="http://cyberelk.net/tim/libieee1284"
arch="all"
-options="!check"
license="GPL2"
-depends=""
depends_dev="py-$pkgname"
makedepends="file python2-dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc py-$pkgname:_py"
source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
include.patch"
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check"
build() {
cd "$builddir"
+
./configure \
--prefix=/usr \
- --mandir=/usr/share/man \
- || return 1
- make || return 1
+ --mandir=/usr/share/man
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
dev() {
- default_dev || return 1
+ default_dev
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
@@ -40,6 +38,7 @@ _py() {
provides="py2-$pkgname"
depends="python2"
pkgdesc="$pkgdesc (python2 bindings)"
+
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/python2* "$subpkgdir"/usr/lib
}