aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libimagequant
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2018-06-23 22:02:26 +0200
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-08-02 18:06:15 +0000
commitf4b30069a9774695b4956de6ceb9a3ce49dcd708 (patch)
tree3ad347f4cf51129cf4b36e7584c729c735560a53 /testing/libimagequant
parenta77b9dc26231014ad404fa2d4862741a5ef53353 (diff)
testing/libimagequant: new aport
Diffstat (limited to 'testing/libimagequant')
-rw-r--r--testing/libimagequant/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/libimagequant/APKBUILD b/testing/libimagequant/APKBUILD
new file mode 100644
index 00000000000..5b29aa7e8af
--- /dev/null
+++ b/testing/libimagequant/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=libimagequant
+pkgver=2.12.1
+pkgrel=0
+pkgdesc="Small, portable C library for high-quality conversion of RGBA images to 8-bit indexed-color (palette) images."
+url="https://pngquant.org/lib/"
+arch="all"
+license="GPL-3.0-or-later"
+options="!check" # No test suite
+makedepends="bash"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ImageOptim/libimagequant/archive/$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="2e65d1ccae4e885e200446756496c2446696f0d4c7057d85e40c9ab4d524fed5505584f21f240ce3a7c589b9156ccb117cf5b1562b4851f3fbf14bf11fed0f13 libimagequant-2.12.1.tar.gz"