aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libimobiledevice/01-libressl.patch
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-05-11 14:50:54 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 15:18:54 +0000
commitf55f02836c1c99a815f30191557049b93b808167 (patch)
treee823cbf850a96f2468ba0c7a327874e61899a8c2 /testing/libimobiledevice/01-libressl.patch
parent14f65b6fd3049eaed3cfe7a11a1d280c6a5ab991 (diff)
community/libimobiledevice: move from community
* Modernize APKBUILD * Fix license * Add two upstream patches, fixing OpenSSLv1.1.x build & runtime Closes GH-7597
Diffstat (limited to 'testing/libimobiledevice/01-libressl.patch')
-rw-r--r--testing/libimobiledevice/01-libressl.patch38
1 files changed, 0 insertions, 38 deletions
diff --git a/testing/libimobiledevice/01-libressl.patch b/testing/libimobiledevice/01-libressl.patch
deleted file mode 100644
index 616c0dce745..00000000000
--- a/testing/libimobiledevice/01-libressl.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 69c42078cc5512ba6ed9cbfd2644f501d59c0717 Mon Sep 17 00:00:00 2001
-From: vmanoilov <vladinc@gmail.com>
-Date: Mon, 21 Mar 2016 23:35:01 +0000
-Subject: [PATCH] Update idevice.c
-
----
- src/idevice.c | 16 +++++++++-------
- 1 file changed, 9 insertions(+), 7 deletions(-)
-
-diff --git a/src/idevice.c b/src/idevice.c
-index b776e84..b5c4407 100644
---- a/src/idevice.c
-+++ b/src/idevice.c
-@@ -676,14 +676,16 @@ LIBIMOBILEDEVICE_API idevice_error_t idevice_connection_enable_ssl(idevice_conne
- debug_info("ERROR: Could not create SSL bio.");
- return ret;
- }
-- BIO_set_fd(ssl_bio, (int)(long)connection->data, BIO_NOCLOSE);
-
-- SSL_CTX *ssl_ctx = SSL_CTX_new(SSLv3_method());
-- if (ssl_ctx == NULL) {
-- debug_info("ERROR: Could not create SSL context.");
-- BIO_free(ssl_bio);
-- return ret;
-- }
-+ BIO_set_fd(ssl_bio, (int)(long)connection->data, BIO_NOCLOSE);
-+
-+ SSL_CTX *ssl_ctx = SSL_CTX_new(SSLv23_method());
-+ if (ssl_ctx == NULL) {
-+ debug_info("ERROR: Could not create SSL context.");
-+ BIO_free(ssl_bio);
-+ return ret;
-+
-+ }
-
- BIO* membp;
- X509* rootCert = NULL;
-