aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libinput/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-11-16 20:57:35 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-18 08:27:56 +0000
commitb2b2b0bbb310d8b3046ab962f6344c6e4d317ef8 (patch)
tree7700156a99bff3c8edd586e5249c47f386d789a5 /testing/libinput/APKBUILD
parent8d8ecd0e7caa96f147959a886ea6f9707a1c8a73 (diff)
testing/libinput: new aport
Diffstat (limited to 'testing/libinput/APKBUILD')
-rw-r--r--testing/libinput/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/libinput/APKBUILD b/testing/libinput/APKBUILD
new file mode 100644
index 00000000000..f6e5ae9b9ce
--- /dev/null
+++ b/testing/libinput/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer:
+pkgname=libinput
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Library for handling input devices"
+url="http://www.freedesktop.org/wiki/Software/libinput/"
+arch="all"
+license="custom"
+depends=""
+depends_dev="mtdev-dev eudev-dev libevdev-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+md5sums="3610c80555f4cb13fe61d4c04511e060 libinput-1.1.0.tar.xz"
+sha256sums="673186ea2a0d2b695afaa9758834f9217b175774d9ae222e1b43ff63c663f582 libinput-1.1.0.tar.xz"
+sha512sums="7f014eabed120c00fcd2d8748aed44a8ca31fd30bdda8b289ca63f7d1bebb9c49f1d508707fb0c4a5c7c4a37b58548efdff0e9b7761475f18e1cf787a80520e6 libinput-1.1.0.tar.xz"