aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libkml/20-fix-python3.patch
diff options
context:
space:
mode:
authorHolger Jaekel <holger.jaekel@gmx.de>2019-09-12 17:47:01 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-13 20:06:15 -0300
commitd58177e01e98f84e39c2c7edbddf719cbfccec7b (patch)
tree5f8a4f56dfcbd24aac63ecda233356130df588f4 /testing/libkml/20-fix-python3.patch
parenta8e64e72b454ef497dd92f7f0483c468d8c85702 (diff)
testing/libkml: new aport
Diffstat (limited to 'testing/libkml/20-fix-python3.patch')
-rw-r--r--testing/libkml/20-fix-python3.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/testing/libkml/20-fix-python3.patch b/testing/libkml/20-fix-python3.patch
new file mode 100644
index 00000000000..e71cf798fd3
--- /dev/null
+++ b/testing/libkml/20-fix-python3.patch
@@ -0,0 +1,15 @@
+Author: Holger Jaekel <holger.jaekel@gmx.de>
+Summary: Fix Python 2 syntax
+----
+
+--- a/src/swig/CMakeLists.txt
++++ b/src/swig/CMakeLists.txt
+@@ -10,7 +10,7 @@ if(WITH_PYTHON)
+
+ if(NOT DEFINED PYTHON_INSTALL_DIR)
+ execute_process(COMMAND
+- ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(True)"
++ ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(True))"
+ OUTPUT_VARIABLE PYTHON_INSTALL_DIR
+ OUTPUT_STRIP_TRAILING_WHITESPACE )
+ endif(NOT DEFINED PYTHON_INSTALL_DIR)