aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libktorrent/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-19 17:44:42 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-19 22:54:16 -0300
commit2667fff1d0985e72bb0ca5d4b0f69d68ecf6a9ae (patch)
treea34246e7bdbe18f0c649a7868db1cd6ad56bb9bb /testing/libktorrent/APKBUILD
parent62d2b00d4bd81f0a43d606ab51d60d7f4461f30f (diff)
testing/libktorrent: new aport
Diffstat (limited to 'testing/libktorrent/APKBUILD')
-rw-r--r--testing/libktorrent/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/libktorrent/APKBUILD b/testing/libktorrent/APKBUILD
new file mode 100644
index 00000000000..05bcde438d7
--- /dev/null
+++ b/testing/libktorrent/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libktorrent
+pkgver=2.1
+_ktorrentver=5.1
+pkgrel=0
+arch="all"
+url="https://kde.org/applications/internet/org.kde.ktorrent"
+pkgdesc="A powerful BitTorrent client for KDE"
+license="GPL-2.0-or-later"
+depends_dev="qt5-qtbase-dev karchive-dev kcrash-dev ki18n-dev kio-dev solid-dev boost-dev gmp-dev qca-dev"
+makedepends="$depends_dev extra-cmake-modules"
+checkdepends="xvfb-run"
+source="https://download.kde.org/stable/ktorrent/$_ktorrentver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ # utppolltest is broken
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "utppolltest"
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="28d7a4b8ee45ddcbadb3ca9d6e568120803081b0ecd3e9436ed721860717b98538c522653ea47975123f0819548d0cabe1973baffed887fcbbca11d84ea5ebe4 libktorrent-2.1.tar.xz"