aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libraw1394/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2011-03-08 14:31:11 +0000
committerLeonardo Arena <rnalrd@gmail.com>2011-03-08 14:33:19 +0000
commit87061da629276cc34814c02d32cb001865ea41e6 (patch)
tree358f8ed940da135286fc5d8475d0e5f8a0636575 /testing/libraw1394/APKBUILD
parentcabc18ecb8c78a9b30691fa7d92a80da9781e235 (diff)
testing/libraw1394: new aport
Library to provide access to the IEEE 1394 bus through the Linux 1394 subsystem's raw1394 user space interface
Diffstat (limited to 'testing/libraw1394/APKBUILD')
-rw-r--r--testing/libraw1394/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/libraw1394/APKBUILD b/testing/libraw1394/APKBUILD
new file mode 100644
index 00000000000..8ef66f6dcf5
--- /dev/null
+++ b/testing/libraw1394/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=libraw1394
+pkgver=2.0.5
+pkgrel=0
+pkgdesc="Library to provide access to Linux 1394 subsystem"
+url="http://sourceforge.net/projects/libraw1394"
+arch="all"
+license="GPL"
+depends=
+depends_dev=
+makedepends=""
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgname-$pkgver.tar.gz"
+
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="1db64231c78540c32859b591cb8b40cf libraw1394-2.0.5.tar.gz"