aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libretro-opera/APKBUILD
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-04-05 11:35:19 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-05 16:24:58 +0000
commit19acd8f1dc4ff90a4927784b6b8dbaf45c154591 (patch)
tree7a795e6bd38afcfaa0a54c2dd26d7f10751c6cf7 /testing/libretro-opera/APKBUILD
parentc8ea2914eb03d7af397e2aef0e05e1936c31ef3c (diff)
testing/libretro-opera: new aport
https://github.com/libretro/opera-libretro port of 4DO/libfreedo to libretro
Diffstat (limited to 'testing/libretro-opera/APKBUILD')
-rw-r--r--testing/libretro-opera/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/libretro-opera/APKBUILD b/testing/libretro-opera/APKBUILD
new file mode 100644
index 00000000000..23358b3564d
--- /dev/null
+++ b/testing/libretro-opera/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=libretro-opera
+pkgver=0_git20200217
+pkgrel=0
+_commit="27bc2653ed469072a6a95102a8212a35fbb1e590"
+pkgdesc="port of 4DO/libfreedo to libretro"
+url="https://github.com/libretro/opera-libretro"
+arch="all"
+license="custom"
+source="$pkgname-$_commit.tar.gz::https://github.com/libretro/opera-libretro/archive/$_commit.tar.gz"
+builddir="$srcdir/opera-libretro-$_commit"
+options="!check" # No tests
+
+build() {
+ make
+}
+
+package() {
+ install -Dm644 opera_libretro.so "$pkgdir"/usr/lib/libretro/opera_libretro.so
+}
+
+sha512sums="3c29190faeb87d98c7f0cf891344590f72088f85791670a316298dceb642187166e41eb7fe82eac63664d30ed847edaa2b46096ffd6c067e376c6499a7220f8a libretro-opera-27bc2653ed469072a6a95102a8212a35fbb1e590.tar.gz"