aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libutempter/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-07-24 10:35:56 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-07-24 10:36:00 +0000
commit1b194a5a32adb133491572e509b8b40cbcea4e9b (patch)
treee58142731a1361cec5832122455d88a09c982cd0 /testing/libutempter/APKBUILD
parentd37cff4d33fd463a287edb932a3a523efde63cd6 (diff)
testing/libutempter: new aport
Diffstat (limited to 'testing/libutempter/APKBUILD')
-rw-r--r--testing/libutempter/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/libutempter/APKBUILD b/testing/libutempter/APKBUILD
new file mode 100644
index 00000000000..ee5f8d88c16
--- /dev/null
+++ b/testing/libutempter/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=libutempter
+pkgver=1.1.6
+pkgrel=0
+pkgdesc="Library interface to record user sessions in utmp/wtmp files"
+url="http://freecode.com/projects/libutempter"
+arch="all"
+license="LGPL-2.1"
+subpackages="$pkgname-dev $pkgname-doc"
+options="suid !check"
+pkggroups="utmp"
+source="ftp://ftp.altlinux.org/pub/people/ldv/utempter/$pkgname-$pkgver.tar.bz2
+ libutempter-remove-glibc-assumption.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ chown root:$pkggroups "$pkgdir/usr/lib/utempter/utempter"
+ chmod 2755 "$pkgdir/usr/lib/utempter/utempter"
+}
+
+sha512sums="6ada410b981d157ae20b578de8ce20997ec0446ec6de6859549b080aa65976fc9900d211600dab09dc3d0d109daabad0994a648b093b8781b442ff26ca17fede libutempter-1.1.6.tar.bz2
+2d487a44ae3c84417f3dd55917ae707bee682b811ebe7aefe8b50aa9f309f879a7f9ed5cbce08119b6fea7dfddb97702348cfbb05ed45e79f95952d15f0366ff libutempter-remove-glibc-assumption.patch"