aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libwbxml
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-05-23 19:08:16 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-23 20:58:08 +0000
commit6832c63e93af15411c749a6ccaf0cb038b146550 (patch)
tree3766404f99787f5e546e8f4d6e95a9fe758c74ab /testing/libwbxml
parent323082dfcd4ddd08d55122e4436900f327511420 (diff)
testing/libwbxml: new aport
Closes GH-8022
Diffstat (limited to 'testing/libwbxml')
-rw-r--r--testing/libwbxml/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/libwbxml/APKBUILD b/testing/libwbxml/APKBUILD
new file mode 100644
index 00000000000..228bbe9dfef
--- /dev/null
+++ b/testing/libwbxml/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=libwbxml
+pkgver=0.11.6
+pkgrel=0
+pkgdesc="A library to encode and decode WBXML (WAP Binary XML)."
+url="https://github.com/libwbxml/libwbxml"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="cmake expat-dev"
+checkdepends="check-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/libwbxml/libwbxml/archive/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgname-$pkgver"
+
+build() {
+ mkdir build && cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_UNIT_TEST=ON
+ make
+}
+
+check() {
+ cd "$builddir/build"
+ make test
+}
+
+package() {
+ cd "$builddir/build"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="a862afc0d8c997dfe3a8723b8580ca81ea28a205ca9129ef4756cc82ceca66fae51692a46f4227d4e871dd572bc2c9c8389844cd978ff06a91fb118917c06759 libwbxml-0.11.6.tar.gz"