aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libxcvt/APKBUILD
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2021-10-27 18:11:01 +0000
committerMilan P. Stanić <mps@arvanta.net>2021-10-27 19:33:56 +0000
commitcdf5e16c70c6d1aae5bac491fd86588adfa8f097 (patch)
tree38b510e53c254a2b91bbf6a7f2c70b637a4374e7 /testing/libxcvt/APKBUILD
parent5705ba72c2e2fe06b77a0555d5dbc9613c5d2049 (diff)
testing/libxcvt: new aport
https://gitlab.freedesktop.org/xorg/lib/libxcvt ibrary providing a standalone version of the X server implementation of the VESA CVT standard timing modelines generator
Diffstat (limited to 'testing/libxcvt/APKBUILD')
-rw-r--r--testing/libxcvt/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/libxcvt/APKBUILD b/testing/libxcvt/APKBUILD
new file mode 100644
index 00000000000..47add871cd7
--- /dev/null
+++ b/testing/libxcvt/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=libxcvt
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="xorg xcvt library and cvt program"
+url="https://gitlab.freedesktop.org/xorg/lib/libxcvt"
+arch="all"
+license="custom"
+makedepends="meson"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://xorg.freedesktop.org/releases/individual/lib/libxcvt-$pkgver.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=plain \
+ . output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
+}
+
+check() {
+ meson test --no-rebuild -v -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+ install -D -m644 "$srcdir"/$pkgname-$pkgver/COPYING \
+ "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+sha512sums="
+50e9cd0283858823d4cfde75f06e23ffc42983272cb1f75408052fb5b76a4bb6f9de7d42d8ff9ec0dae6e95eefebc6273e03c919a92f237585db55eaf1a57005 libxcvt-0.1.1.tar.xz
+"