aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libxml++
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-03-22 15:17:51 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-03-23 07:58:01 +0000
commitbde9bca0bd0af8fa7a5d508c867dcd8771be86bc (patch)
tree74542540661a3d6c46aec7acc8c3b7d5c769de04 /testing/libxml++
parent7c1000dda179cacc3dd541b2f010a7fccb7b52fd (diff)
testing/libxml++ : added .pc file not installed by default
Diffstat (limited to 'testing/libxml++')
-rw-r--r--testing/libxml++/APKBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/testing/libxml++/APKBUILD b/testing/libxml++/APKBUILD
index a3a5858b77b..5fa142ca986 100644
--- a/testing/libxml++/APKBUILD
+++ b/testing/libxml++/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=libxml++
pkgver=3.0.1
-pkgrel=0
+pkgrel=1
pkgdesc="libbxml++ is a C++ wrapper for the libxml XML parser library."
url="http://libxmlplusplus.sourceforge.net/"
arch="all"
license="GPL2"
makedepends="libxml2-dev glibmm-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://ftp.gnome.org/pub/GNOME/sources/$pkgname/${pkgver:0:3}/$pkgname-$pkgver.tar.xz"
+source="http://ftp.gnome.org/pub/GNOME/sources/$pkgname/${pkgveri%.[0-9]*}/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -21,6 +21,12 @@ build() {
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir"/$pkgname-${pkgver%.[0-9]*}.pc "$pkgdir"/usr/lib/pkgconfig/${pkgname%.[0-9]*}.pc
+}
+
+check() {
+ cd "$builddir"
+ make check
}
md5sums="9e95424a1c7231db91ce4058546de461 libxml++-3.0.1.tar.xz"