aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libxml2/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2009-02-04 09:22:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-02-04 12:14:19 +0000
commit7b56e5a8249d7d7a0cf916dcfc27e284af51be92 (patch)
treee06d80f76183e651096b7e833f35080af12f2ce6 /testing/libxml2/APKBUILD
parent3bbbf7e5d8cec7bbdf388a6e591678543d70ba01 (diff)
testing/libxml2: new abuild
Diffstat (limited to 'testing/libxml2/APKBUILD')
-rw-r--r--testing/libxml2/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/libxml2/APKBUILD b/testing/libxml2/APKBUILD
new file mode 100644
index 00000000000..9adcc28358e
--- /dev/null
+++ b/testing/libxml2/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Carlo Landmeter <clandmeter at gmail>
+# Maintainer: Carlo Landmeter <clandmeter at gmail>
+pkgname=libxml2
+pkgver=2.7.2
+pkgrel=0
+pkgdesc="XML parsing library, version 2"
+url="http://www.xmlsoft.org/"
+license="custom"
+depends="zlib"
+makedepends="zlib-dev"
+subpackages="$pkgname-doc $pkgname-dev"
+source="ftp://ftp.xmlsoft.org/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+ make -j1 DESTDIR="$pkgdir" install
+
+}
+
+md5sums="dc43ff7ae6aded45f578c87b7b0c8766 libxml2-2.7.2.tar.gz"