aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libzapojit/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-20 09:07:16 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-20 09:07:31 +0100
commite42f79c57726b9ea0e854ca04fc43c56aac5af54 (patch)
treee1a67bb561d901f1622bac46f8093d87eb2df9cb /testing/libzapojit/APKBUILD
parent86317da5622f4bbbcda0c78043d513b90bb64a69 (diff)
testing/libzapojit: new aport
https://gitlab.gnome.org/GNOME/libzapojit GLib/GObject wrapper for the SkyDrive and Hotmail REST APIs
Diffstat (limited to 'testing/libzapojit/APKBUILD')
-rw-r--r--testing/libzapojit/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/libzapojit/APKBUILD b/testing/libzapojit/APKBUILD
new file mode 100644
index 00000000000..c57ca8f7309
--- /dev/null
+++ b/testing/libzapojit/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=libzapojit
+pkgver=0.0.3_git20190715
+# Use git version, latest tarball is 7 years old...
+_sha=5a13e732daf08dc28db2133e3d0a1066f3e227bd
+pkgrel=0
+pkgdesc="GLib/GObject wrapper for the SkyDrive and Hotmail REST APIs"
+url="https://gitlab.gnome.org/GNOME/libzapojit"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="automake autoconf libtool glib-dev json-glib-dev rest-dev libsoup-dev
+ gnome-online-accounts-dev gtk-doc gobject-introspection-dev"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
+source="https://gitlab.gnome.org/GNOME/libzapojit/-/archive/$_sha.tar.gz"
+builddir="$srcdir/libzapojit-$_sha"
+
+prepare() {
+ default_prepare
+
+ sed '/AX_CHECK_ENABLE_DEBUG/d' -i configure.ac
+ aclocal --install --force
+ gtkdocize
+ autoreconf -fi
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="458d4f000adf3bb72bd970134b0b4f59456a37bf6ec445adc76b4ba66be9548bfaa1699e6ae96f363aff904b9d869234892cf927bed4b337a5b2c45acbd518f2 5a13e732daf08dc28db2133e3d0a1066f3e227bd.tar.gz"