aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lighttpd/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-01-28 09:54:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-01-28 09:54:06 +0000
commitdd2ca47b0e8a060df2f98b6948b1a2a8283035fa (patch)
treed7fb74b63674e61922dc489fe2b0ea78c15635ce /testing/lighttpd/APKBUILD
parent4b20e04e42213df4fed3f9b1a32d2853a7564380 (diff)
testing/lighttpd: use default config and scripts from gentoo
Diffstat (limited to 'testing/lighttpd/APKBUILD')
-rw-r--r--testing/lighttpd/APKBUILD53
1 files changed, 36 insertions, 17 deletions
diff --git a/testing/lighttpd/APKBUILD b/testing/lighttpd/APKBUILD
index 40f61949948..ced02514f21 100644
--- a/testing/lighttpd/APKBUILD
+++ b/testing/lighttpd/APKBUILD
@@ -1,6 +1,6 @@
pkgname=lighttpd
pkgver=1.4.20
-pkgrel=1
+pkgrel=2
pkgdesc="a secure, fast, compliant and very flexible web-server"
url="http://www.lighttpd.net/"
license="custom"
@@ -11,11 +11,18 @@ source="http://www.$pkgname.net/download/$pkgname-$pkgver.tar.bz2
$pkgname.initd
$pkgname.confd
$pkgname.install
- $pkgname.logrotate"
+ $pkgname.logrotate
+ spawn-fcgi.confd
+ spawn-fcgi.initd
+ lighttpd.conf
+ mime-types.conf
+ mod_cgi.conf
+ mod_fastcgi.conf
+ "
subpackages="$pkgname-dev $pkgname-doc"
-build ()
-{
+build() {
+ local i
cd $srcdir/$pkgname-$pkgver
./configure --prefix=/usr \
--enable-lfs \
@@ -32,23 +39,35 @@ build ()
--with-bzip2 \
--with-openssl \
--with-lua || return 1
+
make || return 1
make DESTDIR="$pkgdir" install || return 1
- install -D -m755 ../lighttpd.initd $pkgdir/etc/init.d/lighttpd
- install -D -m644 ../lighttpd.logrotate $pkgdir/etc/logrotate.d/lighttpd
- install -d -m755 $pkgdir/var/run/lighttpd/
- install -d -m755 $pkgdir/var/log/lighttpd/
- install -D -m644 doc/lighttpd.conf $pkgdir/etc/lighttpd/lighttpd.conf
- sed -e 's|/srv/www/htdocs/|/srv/http/|' \
- -e 's|/srv/www/|/srv/http/|' \
- -e 's|#server.username.*|server.username = "lighttpd"|' \
- -e 's|#server.groupname.*|server.groupname = "lighttpd"|' \
- -e 's|#server.pid-file.*|server.pid-file = "/var/run/lighttpd/lighttpd.pid"|' \
- -e 's|/usr/local/bin/php-cgi|/usr/bin/php-cgi|' \
- -i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
+
+ # create dirs
+ install -d -m755 "$pkgdir"/var/run/lighttpd/ \
+ "$pkgdir"/var/log/lighttpd/ \
+ "$pkgdir"/etc/lighttpd/ \
+ "$pkgdir"/var/www/localhost/htdocs
+
+ # lighttpd
+ install -D -m755 "$srcdir"/lighttpd.initd "$pkgdir"/etc/init.d/lighttpd
+ install -D -m644 "$srcdir"/lighttpd.confd "$pkgdir"/etc/conf.d/lighttpd
+ install -D -m644 "$srcdir"/lighttpd.logrotate \
+ "$pkgdir"/etc/logrotate.d/lighttpd
+
+ # spawn-fcgi
+ install -D -m755 "$srcdir"/spawn-fcgi.initd \
+ "$pkgdir"/etc/init.d/spawn-fcgi
+ install -D -m644 "$srcdir"/spawn-fcgi.confd \
+ "$pkgdir"/etc/conf.d/spawn-fcgi
+
+ # config files
+ for i in lighttpd.conf mime-types.conf mod_cgi.conf mod_fastcgi.conf; do
+ install -m644 "$srcdir"/$i "$pkgdir"/etc/lighttpd/$i
+ done
}
md5sums="ed6ee0bb714f393219a32768d86984d8 lighttpd-1.4.20.tar.bz2
6910842e8ba496e8aa984ab30a46eb72 lighttpd.initd
0dede109282bfe685bdec6b35f0e4b6b lighttpd.confd
-43b7be0663ee373047f17ec14def5d21 lighttpd.install
+9b1aa3c58f50afee7c03b414c28de6f6 lighttpd.install
ad091c9157134890499f26d170352c9f lighttpd.logrotate"