aboutsummaryrefslogtreecommitdiffstats
path: root/testing/linux-tools/tools-iio-Correctly-add-make-dependency-for-iio_utils.patch
diff options
context:
space:
mode:
authorMinecrell <minecrell@minecrell.net>2020-03-30 14:33:05 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-20 08:31:31 +0000
commit39cd04888d2f5c04ada5e43156a61e5a152464cb (patch)
tree6643c5e92788a5e02b03fe9e2f9e25c423306779 /testing/linux-tools/tools-iio-Correctly-add-make-dependency-for-iio_utils.patch
parent0c35cac407b9e59857584095a3e4ec75ffedc59d (diff)
testing/linux-tools: package GPIO+IIO tools
Remove depends="cpupower perf" from linux-tools: - I'm not sure how useful it is... (Do you really want all Linux tools at the same time?) - At the moment the dependency leaks into all subpackages (e.g. linux-tools-iio also has a dependency on cpupower/perf) Backport a fix from upstream to fix build failure on s390x. (It's probably just unfortunate to hit this race condition...)
Diffstat (limited to 'testing/linux-tools/tools-iio-Correctly-add-make-dependency-for-iio_utils.patch')
-rw-r--r--testing/linux-tools/tools-iio-Correctly-add-make-dependency-for-iio_utils.patch77
1 files changed, 77 insertions, 0 deletions
diff --git a/testing/linux-tools/tools-iio-Correctly-add-make-dependency-for-iio_utils.patch b/testing/linux-tools/tools-iio-Correctly-add-make-dependency-for-iio_utils.patch
new file mode 100644
index 00000000000..e09a27b2cc4
--- /dev/null
+++ b/testing/linux-tools/tools-iio-Correctly-add-make-dependency-for-iio_utils.patch
@@ -0,0 +1,77 @@
+From: Laura Abbott <labbott@redhat.com>
+Subject: [PATCH] tools: iio: Correctly add make dependency for iio_utils
+Date: Fri, 18 Oct 2019 13:29:08 -0400
+Message-Id: <20191018172908.3761-1-labbott@redhat.com>
+X-Mailer: git-send-email 2.21.0
+MIME-Version: 1.0
+Content-Transfer-Encoding: 8bit
+
+iio tools fail to build correctly with make parallelization:
+
+$ make -s -j24
+fixdep: error opening depfile: ./.iio_utils.o.d: No such file or directory
+make[1]: *** [/home/labbott/linux_upstream/tools/build/Makefile.build:96: iio_utils.o] Error 2
+make: *** [Makefile:43: iio_event_monitor-in.o] Error 2
+make: *** Waiting for unfinished jobs....
+
+This is because iio_utils.o is used across multiple targets.
+Fix this by making iio_utils.o a proper dependency.
+
+Signed-off-by: Laura Abbott <labbott@redhat.com>
+---
+I realize that we don't really need the parallelization for tools
+because it's so small but when building with the distro we want to use
+the same make command and -j wherever possible.
+
+This same issue also appears in the gpio tools so if this looks like an
+okay approach I'll fix it there as well.
+---
+ tools/iio/Build | 1 +
+ tools/iio/Makefile | 10 +++++++---
+ 2 files changed, 8 insertions(+), 3 deletions(-)
+
+diff --git a/tools/iio/Build b/tools/iio/Build
+index f74cbda64710..8d0f3af3723f 100644
+--- a/tools/iio/Build
++++ b/tools/iio/Build
+@@ -1,3 +1,4 @@
++iio_utils-y += iio_utils.o
+ lsiio-y += lsiio.o iio_utils.o
+ iio_event_monitor-y += iio_event_monitor.o iio_utils.o
+ iio_generic_buffer-y += iio_generic_buffer.o iio_utils.o
+diff --git a/tools/iio/Makefile b/tools/iio/Makefile
+index e22378dba244..3de763d9ab70 100644
+--- a/tools/iio/Makefile
++++ b/tools/iio/Makefile
+@@ -32,20 +32,24 @@ $(OUTPUT)include/linux/iio: ../../include/uapi/linux/iio
+
+ prepare: $(OUTPUT)include/linux/iio
+
++IIO_UTILS_IN := $(OUTPUT)iio_utils-in.o
++$(IIO_UTILS_IN): prepare FORCE
++ $(Q)$(MAKE) $(build)=iio_utils
++
+ LSIIO_IN := $(OUTPUT)lsiio-in.o
+-$(LSIIO_IN): prepare FORCE
++$(LSIIO_IN): prepare FORCE $(OUTPUT)iio_utils-in.o
+ $(Q)$(MAKE) $(build)=lsiio
+ $(OUTPUT)lsiio: $(LSIIO_IN)
+ $(QUIET_LINK)$(CC) $(CFLAGS) $(LDFLAGS) $< -o $@
+
+ IIO_EVENT_MONITOR_IN := $(OUTPUT)iio_event_monitor-in.o
+-$(IIO_EVENT_MONITOR_IN): prepare FORCE
++$(IIO_EVENT_MONITOR_IN): prepare FORCE $(OUTPUT)iio_utils-in.o
+ $(Q)$(MAKE) $(build)=iio_event_monitor
+ $(OUTPUT)iio_event_monitor: $(IIO_EVENT_MONITOR_IN)
+ $(QUIET_LINK)$(CC) $(CFLAGS) $(LDFLAGS) $< -o $@
+
+ IIO_GENERIC_BUFFER_IN := $(OUTPUT)iio_generic_buffer-in.o
+-$(IIO_GENERIC_BUFFER_IN): prepare FORCE
++$(IIO_GENERIC_BUFFER_IN): prepare FORCE $(OUTPUT)iio_utils-in.o
+ $(Q)$(MAKE) $(build)=iio_generic_buffer
+ $(OUTPUT)iio_generic_buffer: $(IIO_GENERIC_BUFFER_IN)
+ $(QUIET_LINK)$(CC) $(CFLAGS) $(LDFLAGS) $< -o $@
+--
+2.21.0
+
+