aboutsummaryrefslogtreecommitdiffstats
path: root/testing/livestreamer
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-07 13:40:25 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-12 16:20:30 -0300
commit53b2d33288b7c6333d006e29599882c0fd0e3a8b (patch)
tree48af01563152dfdae3c5e40949190e9c73340fc7 /testing/livestreamer
parentd684126c856e4f222276afccc2bb31715edc686c (diff)
testing/livestreamer: fix license, modernize
Diffstat (limited to 'testing/livestreamer')
-rw-r--r--testing/livestreamer/APKBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/testing/livestreamer/APKBUILD b/testing/livestreamer/APKBUILD
index 6cbaa4aa593..4cd061415c3 100644
--- a/testing/livestreamer/APKBUILD
+++ b/testing/livestreamer/APKBUILD
@@ -2,31 +2,26 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=livestreamer
pkgver=1.12.2
-pkgrel=3
+pkgrel=4
pkgdesc="Command-line utility that extracts streams from various services and pipes them into a video player of choice"
url="https://livestreamer.io/"
arch="noarch"
-license="BSD"
+license="BSD-2-Clause"
depends="py-requests rtmpdump py-setuptools py2-singledispatch py-futures py-six py-crypto py-librtmp"
makedepends="py-sphinx"
source="$pkgname-$pkgver.tar.gz::https://github.com/chrippa/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
python2 setup.py build
}
check() {
- cd "$builddir"
python2 setup.py test
}
package() {
- cd "$builddir"
python2 setup.py install --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
sha512sums="547886b494a7562e479cf31db15b5b02545f2ebc5f8b70d0fe0006d3748c5c9f20517638c7642377e2bdc4083738829eacf272e8d68f332da212bf65300f5d12 livestreamer-1.12.2.tar.gz"