aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lldb/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-22 02:26:04 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-22 02:45:59 +0200
commitf0e069b8efa2ee899130122ec6ccfaa7f11a99b4 (patch)
tree7c9a9537b398abe7d1f148a5d53e616e3c4b3557 /testing/lldb/APKBUILD
parentbcf2365f6d4744f3b0be6854e098f280f41b5c1b (diff)
testing/lldb: fix and improve abuild, rename subpkg py- to py2-
Diffstat (limited to 'testing/lldb/APKBUILD')
-rw-r--r--testing/lldb/APKBUILD61
1 files changed, 29 insertions, 32 deletions
diff --git a/testing/lldb/APKBUILD b/testing/lldb/APKBUILD
index 789ba80d0fc..56fbab38918 100644
--- a/testing/lldb/APKBUILD
+++ b/testing/lldb/APKBUILD
@@ -1,60 +1,57 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
# Maintainer:
-
pkgname=lldb
pkgver=3.8.1
-pkgrel=0
+pkgrel=1
pkgdesc="Next generation, high-performance debugger"
arch="all"
url="http://llvm.org/"
license="UOI-NCSA"
-makedepends="clang clang-libs clang-dev cmake doxygen libedit-dev libffi-dev
- libxml2-dev linux-headers llvm llvm-libs llvm-dev llvm-static ncurses-dev
+makedepends="clang-dev cmake doxygen libedit-dev libffi-dev
+ libxml2-dev linux-headers llvm-dev llvm-static ncurses-dev
ninja python2-dev swig"
-subpackages="$pkgname-dev py-$pkgname:py $pkgname-libs"
-source="http://llvm.org/releases/$pkgver/lldb-$pkgver.src.tar.xz
+subpackages="$pkgname-dev py2-$pkgname:py2"
+source="http://llvm.org/releases/$pkgver/$pkgname-$pkgver.src.tar.xz
lldb-3.8-alpine.patch
D15067.id41365.patch
musl-include-ptrace.aarch64.patch"
-builddir="$srcdir/build"
-
-_srcdir="$srcdir/lldb-$pkgver.src"
-
-prepare() {
- local builddir="$_srcdir"
- default_prepare
-}
+builddir="$srcdir/$pkgname-$pkgver.src"
build() {
- mkdir -p "$builddir"
- cd "$builddir"
+ mkdir -p "$builddir"/build
+ cd "$builddir"/build
- cmake -G Ninja -Wno-dev \
+ cmake .. -G Ninja -Wno-dev \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
- "$_srcdir" || return 1
-
- ninja || return 1
+ -DLLVM_LINK_LLVM_DYLIB=ON
+ ninja
}
package() {
- cd "$builddir"
- DESTDIR="$pkgdir" ninja install || return 1
+ cd "$builddir"/build
+
+ DESTDIR="$pkgdir" ninja install
+
+ # Remove static libraries.
+ rm -f "$pkgdir"/usr/lib/*.a
}
-py() {
- depends="py-six"
+py2() {
+ pkgdesc="Python module for LLDB"
+ depends="$pkgname py2-six"
+ replaces="py-lldb"
+ local sitedir="usr/lib/python2.7/site-packages"
+
+ mkdir -p "$subpkgdir"/$sitedir
+ cd "$subpkgdir"
- mkdir -p "$subpkgdir/usr/lib"
- mv "$pkgdir/usr/lib/python2.7" "$subpkgdir/usr/lib" || return 1
+ mv "$pkgdir"/$sitedir ${sitedir%/*}/
- rm "$subpkgdir/usr/lib/python2.7/site-packages/six.py"
+ # Remove bundled module.
+ rm $sitedir/six.py
- python2 -m compileall \
- "$subpkgdir/usr/lib/python2.7/site-packages/lldb" || return 1
- python2 -O -m compileall \
- "$subpkgdir/usr/lib/python2.7/site-packages/lldb" || return 1
+ python2 -m compileall -fqd /$sitedir $sitedir
}
md5sums="9e4787b71be8e432fffd31e13ac87623 lldb-3.8.1.src.tar.xz