aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lua5.2-penlight
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-26 11:10:07 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-26 11:10:07 +0200
commita39e19f96447a409ae6f6c1c63d3c16feb1a3991 (patch)
tree148fdebc95bfd8788f91996703d2094c1b8df4da /testing/lua5.2-penlight
parentc5240dc4d2a5efc26b94c943d87848e51ba2794b (diff)
unmaintained/[multiple] move back packages to testing
move back packages that are depends of other packages in testing
Diffstat (limited to 'testing/lua5.2-penlight')
-rw-r--r--testing/lua5.2-penlight/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/lua5.2-penlight/APKBUILD b/testing/lua5.2-penlight/APKBUILD
new file mode 100644
index 00000000000..f4bd333a8bd
--- /dev/null
+++ b/testing/lua5.2-penlight/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_luaver=5.2
+pkgname=lua${_luaver}-penlight
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="Lua libraries for extended operations on tables, lists and strings"
+url="https://github.com/stevedonovan/Penlight"
+arch="noarch"
+license="GPL"
+depends="lua${_luaver}-filesystem"
+makedepends="wget"
+install=
+subpackages="$pkgname-doc"
+source="penlight-$pkgver.tar.gz::https://github.com/stevedonovan/Penlight/archive/$pkgver.tar.gz"
+
+_builddir="$srcdir"/Penlight-$pkgver
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/share/lua/$_luaver/ \
+ "$pkgdir"/usr/share/doc/$pkgname
+ cp -r lua/pl "$pkgdir"/usr/share/lua/$_luaver/ || return 1
+ cp -r doc/* "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+ cp -r examples "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+}
+
+md5sums="7add43a98a940fb066b873c1298c4489 penlight-1.3.0.tar.gz"
+sha256sums="5f0be532df2c72926280f22eb61a2f62557f7d29b576c82fd573f2d35a8f1114 penlight-1.3.0.tar.gz"
+sha512sums="d38764f25219646e0772ed2df50bb8c31bf2067b7676d841848735a5c9fd81d169b0972c4db46ad3ceb53849fa25ec2bae0c5e053c03533fb383afdd1e9d44f9 penlight-1.3.0.tar.gz"