aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mate-common/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-12-16 15:52:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-12-16 15:52:39 +0000
commit3ad339b015f3e647b9a0b394d5ee386a7b0220dc (patch)
treed9f59bc080ea671e323f94de798534522fd6cda0 /testing/mate-common/APKBUILD
parenta9e59d52bb2fce068924495b6a9d831f30555447 (diff)
testing/mate-common: fix license
and do not needlessly regenerate configure script
Diffstat (limited to 'testing/mate-common/APKBUILD')
-rw-r--r--testing/mate-common/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/testing/mate-common/APKBUILD b/testing/mate-common/APKBUILD
index f6895daaa84..4473aa519c0 100644
--- a/testing/mate-common/APKBUILD
+++ b/testing/mate-common/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer:
pkgname=mate-common
pkgver=1.9.0
-pkgrel=0
+pkgrel=1
pkgdesc="Common scripts and macros"
url="http://mate-desktop.org/"
arch="noarch"
-license="CC"
+license="GPLv3+"
depends=""
depends_dev=""
-makedepends="autoconf automake gettext"
+makedepends=""
install=""
subpackages=""
source="http://pub.mate-desktop.org/releases/1.9/$pkgname-$pkgver.tar.xz"
@@ -27,8 +27,13 @@ prepare() {
build() {
cd "$_builddir"
- ./autogen.sh --prefix=/usr || return 1
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
make || return 1
+
}
package() {