aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mate-tweak/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-04 14:22:48 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-04 14:22:48 +0000
commit2440ce9bdd58ae5f05d4ee9bad17d02a84bf802c (patch)
tree8da9b07e4a4cf2ec498db5bfd8f3afce782d8b6d /testing/mate-tweak/APKBUILD
parentd7d1449d30e8a8b71e18cbdad928e766b68c64cd (diff)
testing/mate-tweak: new aport
Tweak tool for the MATE Desktop
Diffstat (limited to 'testing/mate-tweak/APKBUILD')
-rw-r--r--testing/mate-tweak/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/mate-tweak/APKBUILD b/testing/mate-tweak/APKBUILD
new file mode 100644
index 00000000000..bfafb1ca232
--- /dev/null
+++ b/testing/mate-tweak/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
+pkgname=mate-tweak
+pkgver=18.04.16
+pkgrel=0
+pkgdesc="Tweak tool for the MATE Desktop"
+url="https://github.com/ubuntu-mate/mate-tweak"
+arch="all"
+license="GPL-2.0"
+depends="python3 py-setproctitle"
+makedepends="python3-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ubuntu-mate/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="33d10536e3c6f7b75d728fcc3513080f47183828c87403bd3445ac523f602f62ee40724b25ae0f399eea931f1dbb8c89625112d36861f4befd4a8caa7ab4f273 mate-tweak-18.04.16.tar.gz"