aboutsummaryrefslogtreecommitdiffstats
path: root/testing/milter-greylist/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2016-04-22 13:45:18 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2016-04-22 13:45:32 +0000
commit57bb77c0bd139634757c4eb1406f0de041e72244 (patch)
tree87189376cbce99a1e8e126944480c0c4e7d5ef36 /testing/milter-greylist/APKBUILD
parentb7680a3725d4f2f8c937b6710f4fa82d5f21750d (diff)
testing/milter-greylist: change conf dir, enable spamassassin support
Diffstat (limited to 'testing/milter-greylist/APKBUILD')
-rw-r--r--testing/milter-greylist/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/testing/milter-greylist/APKBUILD b/testing/milter-greylist/APKBUILD
index 75780798b63..d93daae7d75 100644
--- a/testing/milter-greylist/APKBUILD
+++ b/testing/milter-greylist/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=milter-greylist
pkgver=4.4.3
-pkgrel=2
+pkgrel=3
pkgdesc="Stand-alone milter written in C that implements the greylist filtering method"
url="http://hcpnet.free.fr/milter-greylist"
arch="all"
@@ -41,7 +41,11 @@ build() {
--localstatedir=/var/lib \
--with-libspf2 \
--with-user=smmsp \
+ --with-conffile=/etc/$pkgname/greylist.conf \
+ --with-dumpfile=/var/lib/$pkgname/greylist.db \
+ --with-libbind \
--enable-postfix \
+ --enable-spamassassin \
--disable-rpath
make -j1 || return 1
}
@@ -50,7 +54,7 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
install -m755 -D ../../$pkgname.initd "$pkgdir"/etc/init.d/$pkgname || return 1
- install -m644 greylist2.conf "$pkgdir"/etc/mail/greylist2.conf
+ install -m644 greylist2.conf "$pkgdir"/etc/$pkgname/greylist2.conf
chown -R smmsp:smmsp "$pkgdir"/var/lib/$pkgname
}