aboutsummaryrefslogtreecommitdiffstats
path: root/testing/monado/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-02-16 11:25:31 +0100
committerLeo <thinkabit.ukim@gmail.com>2021-02-16 10:35:27 +0000
commit65beedf68e5cf6811264981ddd88b8b680a613af (patch)
treee2924e237e62c71ff79afab32c7ee5c37fa63b5d /testing/monado/APKBUILD
parent84ececa8b14a22b755db78ca2f9e11f8eceae5d3 (diff)
testing/monado: disable SteamVR driver
We can't use it anyway
Diffstat (limited to 'testing/monado/APKBUILD')
-rw-r--r--testing/monado/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/testing/monado/APKBUILD b/testing/monado/APKBUILD
index 874767ae7ea..97ed6146de4 100644
--- a/testing/monado/APKBUILD
+++ b/testing/monado/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=monado
pkgver=21.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="The open source OpenXR runtime"
url="https://monado.freedesktop.org"
arch="all !mips64" # blocked by xr-hardware
@@ -36,8 +36,13 @@ source="https://gitlab.freedesktop.org/monado/monado/-/archive/v$pkgver/monado-v
builddir="$srcdir/$pkgname-v$pkgver"
build() {
+ # Steam is not available on Alpine and probably never will be
+ # It can be ran in a Flatpak on Alpine but Monado installed on the host
+ # can never work with it, so there is no need for us to build it
+
abuild-meson . output \
- -Ddrivers=auto,ohmd,survive
+ -Ddrivers=auto,ohmd,survive \
+ -Dsteamvr_plugin=false
meson compile ${JOBS:+-j ${JOBS}} -C output
}