aboutsummaryrefslogtreecommitdiffstats
path: root/testing/monero
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-07-19 15:14:53 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-07-21 12:02:56 +0300
commit1f4e538f405c920db57eb7371adc9304c015dfb0 (patch)
tree8c9c4f2e1e8f9e07269ae8f83f0a439a8c213a71 /testing/monero
parent7d44c0ecd2a7ceafad1c1f98183c480975eebefa (diff)
testing/monero: upgrade to 0.12.3.0
Diffstat (limited to 'testing/monero')
-rw-r--r--testing/monero/APKBUILD12
-rw-r--r--testing/monero/system-miniupnpc.patch101
2 files changed, 108 insertions, 5 deletions
diff --git a/testing/monero/APKBUILD b/testing/monero/APKBUILD
index 1316ed3a0d7..8e14b240f8d 100644
--- a/testing/monero/APKBUILD
+++ b/testing/monero/APKBUILD
@@ -1,17 +1,18 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=monero
-pkgver=0.12.0.0
-pkgrel=2
+pkgver=0.12.3.0
+pkgrel=0
pkgdesc="Secure, private, untraceable cryptocurrency"
url="https://getmonero.org/"
arch="all"
license="BSD"
-makedepends="unbound-dev libressl-dev boost-dev miniupnpc-dev cmake cppzmq zeromq-dev"
+makedepends="unbound-dev libressl-dev boost-dev miniupnpc-dev cmake cppzmq zeromq-dev rapidjson-dev"
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/monero-project/$pkgname/archive/v$pkgver.tar.gz
easylogging.patch
disable-aes-on-s390x.patch
+ system-miniupnpc.patch
"
builddir="$srcdir/"$pkgname-$pkgver
@@ -31,6 +32,7 @@ package() {
install -m755 -t "${pkgdir}"/usr/bin build/bin/*
}
-sha512sums="780465569cdd7cf7f38e5e6dc88f420f411e3768ee0e0421cfb2f1ccb48b2fa93261d8f806f51f7fde44f622395c9b90809fea7bb50ad3470a34b8df80bf882e monero-0.12.0.0.tar.gz
+sha512sums="9e78a66c2f76ebcefd355442f659a9a02298ec34ffca5ee514763b688d999da25cd1b96dd98255bacda7448e783b1c52e8d9effbbf3a75d1f0be1b5788d4b1ca monero-0.12.3.0.tar.gz
71bb3dd1943dd0850221445e93e07597019691a94bf776950ee2bdb334a670d9ec64fb036f42c5df2846493a0aa4f803c7cb46560fcdb5264cf3d8909d66cef0 easylogging.patch
-b6f2a60822d0ad59b15766d84ec69f99aedac01697097244683f52e9bc24e98f2ba3ddf58d7d26055ff075dcc6894f173099b1213b04f281435ee051ad967e90 disable-aes-on-s390x.patch"
+b6f2a60822d0ad59b15766d84ec69f99aedac01697097244683f52e9bc24e98f2ba3ddf58d7d26055ff075dcc6894f173099b1213b04f281435ee051ad967e90 disable-aes-on-s390x.patch
+5abfc9248cf11bc86441622bc7cfd74c52746907fb0fce38a94d6be48d266e779d61135b7911076f11c967d6b8cb065d10aaab38d299a67698b5c8ff41d22d55 system-miniupnpc.patch"
diff --git a/testing/monero/system-miniupnpc.patch b/testing/monero/system-miniupnpc.patch
new file mode 100644
index 00000000000..5cc25a570ed
--- /dev/null
+++ b/testing/monero/system-miniupnpc.patch
@@ -0,0 +1,101 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -430,6 +430,14 @@ include_directories("${CMAKE_CURRENT_BINARY_DIR}/translations")
+
+ add_subdirectory(external)
+
++# Final setup for miniupnpc
++if(UPNP_STATIC OR IOS)
++ add_definitions("-DUPNP_STATIC")
++else()
++ add_definitions("-DUPNP_DYNAMIC")
++ include_directories(${UPNP_INCLUDE})
++endif()
++
+ # Final setup for libunbound
+ include_directories(${UNBOUND_INCLUDE})
+ link_directories(${UNBOUND_LIBRARY_DIRS})
+diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
+index 1fc4d64c..b4f712ee 100644
+--- a/external/CMakeLists.txt
++++ b/external/CMakeLists.txt
+@@ -34,21 +34,42 @@
+ # We always compile if we are building statically to reduce static dependency issues...
+ # ...except for FreeBSD, because FreeBSD is a special case that doesn't play well with
+ # others.
++if(NOT IOS)
++ find_package(Miniupnpc QUIET)
++endif()
+
+-find_package(Miniupnpc REQUIRED)
++# If we have the correct shared version and we're not building static, use it
++if(STATIC OR IOS)
++ set(USE_SHARED_MINIUPNPC false)
++elseif(MINIUPNP_FOUND AND MINIUPNPC_VERSION_1_7_OR_HIGHER)
++ set(USE_SHARED_MINIUPNPC true)
++endif()
+
+-message(STATUS "Using in-tree miniupnpc")
++if(USE_SHARED_MINIUPNPC)
++ message(STATUS "Using shared miniupnpc found at ${MINIUPNP_INCLUDE_DIR}")
+
+-add_subdirectory(miniupnp/miniupnpc)
++ set(UPNP_STATIC false PARENT_SCOPE)
++ set(UPNP_INCLUDE ${MINIUPNP_INCLUDE_DIR} PARENT_SCOPE)
++ set(UPNP_LIBRARIES ${MINIUPNP_LIBRARY} PARENT_SCOPE)
++else()
++ if(STATIC)
++ message(STATUS "Using miniupnpc from local source tree for static build")
++ else()
++ message(STATUS "Using miniupnpc from local source tree (/external/miniupnp/miniupnpc)")
++ endif()
+
+-set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
+-if(MSVC)
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -wd4244 -wd4267")
+-elseif(NOT MSVC)
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -Wno-undef -Wno-unused-result -Wno-unused-value")
+-endif()
++ add_subdirectory(miniupnp/miniupnpc)
++
++ set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
++ if(MSVC)
++ set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -wd4244 -wd4267")
++ elseif(NOT MSVC)
++ set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -Wno-undef -Wno-unused-result -Wno-unused-value")
++ endif()
+
+-set(UPNP_LIBRARIES "libminiupnpc-static" PARENT_SCOPE)
++ set(UPNP_STATIC true PARENT_SCOPE)
++ set(UPNP_LIBRARIES "libminiupnpc-static" PARENT_SCOPE)
++endif()
+
+ find_package(Unbound)
+
+diff --git a/src/p2p/net_node.inl b/src/p2p/net_node.inl
+index 9b21705e..76340a22 100644
+--- a/src/p2p/net_node.inl
++++ b/src/p2p/net_node.inl
+@@ -49,9 +49,16 @@
+ #include "storages/levin_abstract_invoke2.h"
+ #include "cryptonote_core/cryptonote_core.h"
+
+-#include <miniupnp/miniupnpc/miniupnpc.h>
+-#include <miniupnp/miniupnpc/upnpcommands.h>
+-#include <miniupnp/miniupnpc/upnperrors.h>
++// We have to look for miniupnpc headers in different places, dependent on if its compiled or external
++#ifdef UPNP_STATIC
++ #include <miniupnp/miniupnpc/miniupnpc.h>
++ #include <miniupnp/miniupnpc/upnpcommands.h>
++ #include <miniupnp/miniupnpc/upnperrors.h>
++#else
++ #include "miniupnpc.h"
++ #include "upnpcommands.h"
++ #include "upnperrors.h"
++#endif
+
+ #undef MONERO_DEFAULT_LOG_CATEGORY
+ #define MONERO_DEFAULT_LOG_CATEGORY "net.p2p"
+--
+2.17.0
+