aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mongodb
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-02-02 08:41:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-02-02 09:24:59 +0000
commitac7fb85c9e101a3030eb5e1e42cef5896fc19cf8 (patch)
treeeec5a36daa4b5424d4a5e4a709a9bd88db56d0a5 /testing/mongodb
parent53694c791e7c7112a0d8e4b47bdca8fd03edea4e (diff)
testing/mongodb: rebuild against boost-1.60
Diffstat (limited to 'testing/mongodb')
-rw-r--r--testing/mongodb/APKBUILD6
-rw-r--r--testing/mongodb/boost160.patch11
2 files changed, 16 insertions, 1 deletions
diff --git a/testing/mongodb/APKBUILD b/testing/mongodb/APKBUILD
index db714416ae2..99115194d9d 100644
--- a/testing/mongodb/APKBUILD
+++ b/testing/mongodb/APKBUILD
@@ -2,7 +2,7 @@
pkgname=mongodb
pkgver=3.2.1
-pkgrel=0
+pkgrel=1
pkgdesc='A high-performance, open source, schema-free document-oriented database'
url='http://www.mongodb.org'
arch='x86_64'
@@ -18,6 +18,7 @@ source="http://downloads.mongodb.org/src/mongodb-src-r${pkgver}.tar.gz
40-fix-elf-native-class.patch
backtrace.patch
fix-asio-strerror_r.patch
+ boost160.patch
mongodb.confd
mongodb.initd
@@ -94,6 +95,7 @@ md5sums="a9f150f8bead9e8afd3ab28492167073 mongodb-src-r3.2.1.tar.gz
04a348397be8ca7471d404056d8a1490 40-fix-elf-native-class.patch
86a988b5d4402227d177b8a1167008e8 backtrace.patch
cd0833592e3a23e729ebd71eb756318c fix-asio-strerror_r.patch
+1df24dc2aa6b8f4c6da22f097a921ebb boost160.patch
7d2f94bed7bfacd32fcd52dfd931f077 mongodb.confd
792a0b53b3e843cf14176c5beb8cdfe1 mongodb.initd
49df78833de4cb6e2b9b1ab9da52c3ac mongodb.logrotate
@@ -104,6 +106,7 @@ sha256sums="50431a3ba5ab68bd0bed4a157a8528ca27753a63cf101f13135255e4e9d42f15 mo
3a863660113d29728d7a852b3fba73926697b496848f8ccc4d8e73e6614cfdfc 40-fix-elf-native-class.patch
300d9f6b819730de54018d4b418eb7f921ba9c83fad4958a040544b076160848 backtrace.patch
ec6d404221f02706ef2e52e00e414e98666dcc3606e78c9b3d33dfbd42a1eae7 fix-asio-strerror_r.patch
+0e9da35f4303e53daf51e78961c517895f2d12f4fa49298f01e1665e15246d73 boost160.patch
a4ca29c577428c02cd0b0a8b46756df5f53a05519c9d13c270533cf99b9b819d mongodb.confd
7e39fbd4dc18dba21c8767931683f4795e58e0e91b9f9a5842539923ded453c9 mongodb.initd
76994c32d999def5c925bd7be3f96687b3406f1d67b89aa6a4df8053025b1e01 mongodb.logrotate
@@ -114,6 +117,7 @@ b9fdacb273d5a4e1e60735846b262287f84ca6cbded9393d182f69158d3162a50cae5d834f76860d
56db8f43afc94713ac65b174189e2dd903b5e1eff0b65f1bdac159e52ad4de6606c449865d73bd47bffad6a8fc339777e2b11395596e9a476867d94a219c7925 40-fix-elf-native-class.patch
7d097f497cb910c9cb81086cd8c222e43456d1a6de4adfe3e97a4d99add454279350fdeb7305dab84b3deca04afd824036d4065ee0fb8cdd8c03e96d98ee86af backtrace.patch
f829b1ad542db3ee776d444243b8b47ab4e48a7386d9b199d7b1adafd31556cf173a5683b78ee735d6a69999ad9af5ad152fde955bbe8865f7910718991ce97c fix-asio-strerror_r.patch
+385c82875174caae433a3b381eb10f98a6fed0c8943788ddefff1de80a898e480bdbbf094a7783285cf2ae11ce3fc6878e57d58183d05be2f0837b206aaa4da6 boost160.patch
9bcd870742c31bf25f34188ddc3c414de1103e9860dea9f54eee276b89bc2cf1226abab1749c5cda6a6fb0880e541373754e5e83d63cc7189d4b9c274fd555c3 mongodb.confd
2cb295ac0eb44acb4533c86d6d0988d5f760361a43cff7845713f3e2cf0e37023d23790a2926c613bf2b0668060c0b68d59000db52daaacd8af10e701a8b4192 mongodb.initd
8c089b1a11f494e4148fb4646265964c925bf937633a65e395ee1361d42facf837871dd493a9a2e0f480ae0e0829dbd3ed60794c5334e2716332e131fc5c2c51 mongodb.logrotate
diff --git a/testing/mongodb/boost160.patch b/testing/mongodb/boost160.patch
new file mode 100644
index 00000000000..3567c65f824
--- /dev/null
+++ b/testing/mongodb/boost160.patch
@@ -0,0 +1,11 @@
+diff -uprb mongodb-src-r3.2.0.orig/SConstruct mongodb-src-r3.2.0/SConstruct
+--- mongodb-src-r3.2.0.orig/SConstruct 2015-12-02 21:01:34.000000000 +0200
++++ mongodb-src-r3.2.0/SConstruct 2015-12-22 11:18:23.613216445 +0200
+@@ -2245,6 +2245,7 @@ def doConfigure(myenv):
+ # permit more than four parameters.
+ "BOOST_THREAD_DONT_PROVIDE_VARIADIC_THREAD",
+ "BOOST_SYSTEM_NO_DEPRECATED",
++ "BOOST_OPTIONAL_USE_SINGLETON_DEFINITION_OF_NONE",
+ ]
+ )
+